Opened 12 years ago

Closed 12 years ago

#4660 closed patch (fixed)

mythtranscode should drop lock if it detects deadlock

Reported by: Erik Hovland <erik@…> Owned by: Janne Grunau
Priority: minor Milestone: 0.21
Component: mythtranscode Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

In mpeg2fix.cpp there is a conditional that checks to see if a deadlock has occurred. If it is has, it returns. But it doesn't drop any locks it might hold. It ought to.

Attachments (1)

release-lock-on-error-in-mythtranscode.patch (823 bytes) - added by Erik Hovland <erik@…> 12 years ago.
adds a lock release to a failure path in mpeg2fix.cpp

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by Erik Hovland <erik@…>

adds a lock release to a failure path in mpeg2fix.cpp

comment:1 Changed 12 years ago by stuartm

Resolution: duplicate
Status: newclosed

Duplicate of #4659

comment:2 Changed 12 years ago by Janne Grunau

Resolution: duplicate
Status: closednew

comment:3 Changed 12 years ago by Janne Grunau

Owner: changed from Isaac Richards to Janne Grunau
Status: newaccepted

comment:4 Changed 12 years ago by Janne Grunau

(In [15987]) Lets Mythtranscode release it's mutex if it detects a deadlock

From: Erik Hovland <erik@…>

Refs #4660.

comment:5 Changed 12 years ago by Janne Grunau

Resolution: fixed
Status: acceptedclosed

(In [15990]) Fixes #4660. Release mutex before returning on error. Merges [15987] from trunk.

From: Erik Hovland <erik[a]hovland[p]org>

Note: See TracTickets for help on using tickets.