Opened 14 years ago

Closed 14 years ago

#468 closed defect (wontfix)

EIT not filling EPG

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When tuned to a transponder that is known to provide epg data, the backend complains with the following messages:

2005-10-13 21:14:14.882 DVB#0 ERROR - Reading Section. (75) Value too large for defined data type 2005-10-13 21:14:28.847 DVB#0 ERROR - Reading Section. (75) Value too large for defined data type 2005-10-13 21:14:43.285 DVB#0 ERROR - Reading Section. (75) Value too large for defined data type 2005-10-13 21:15:01.241 DVB#0 ERROR - Reading Section. (75) Value too large for defined data type

Timeslots in the epg seem to get populated but there is no data in the actual timeslots. Using svn 7465.

Change History (2)

comment:1 Changed 14 years ago by redmundt@…

The ERROR messages you are seeing above are caused by not reading the demux data fast enough and the demux kernel buffers overflowing. Currently, you lose at least 3 megs of guide data each time you see this message.

comment:2 Changed 14 years ago by danielk

Resolution: wontfix
Status: newclosed

Until there is someone who wants to fix this I'm marking it as won't fix.

The DVB recorder needs a ring buffer like the HDTV recorder uses to avoid losing data while it processes the data it gets from the device.

Note: See TracTickets for help on using tickets.