Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4682 closed defect (fixed)

Animated map doesn't scale per theme description

Reported by: Ash Bostock <abostock@…> Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythweather Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I use the Retro theme which for mythweather uses the default weather-ui.xml as it doesn't define its own.

When on the animated map screen of mythweather the map image is too large for the theme and spills over causing the date to also be pushed off the bottom.

I've tried modifying this part of the weather-ui.xml file...

<animatedimage name="+animatedimage" draworder="6">
<position>35,100</position>
<staticsize>730,450</staticsize>
<interval>200</interval>
<startinterval>1000</startinterval>
</animatedimage>

... specifically the staticsize value, but mythweather seems to pay no attention to it and doesn't scale the image to the provided values.

Attachments (1)

mythweather_staticfix.diff (5.5 KB) - added by stuartm 12 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by stuartm

Milestone: unknown0.21

comment:2 Changed 12 years ago by stuartm

Status: newaccepted

comment:3 Changed 12 years ago by stuartm

(In [16319]) Add an inline method to get the static size of an animated image type.

Refs #4682

Changed 12 years ago by stuartm

Attachment: mythweather_staticfix.diff added

comment:4 Changed 12 years ago by stuartm

Status: acceptedstarted

Ash, could you test the attached patch against current trunk (it depends on a change I just committed). It should honour staticsize and also work if staticsize is omitted from the theme.

comment:5 Changed 12 years ago by stuartm

Resolution: fixed
Status: startedclosed

(In [16322]) Adhere to static size for animated and static map screens. Removed hardcoded defaults. Tweaked default theme (non-wide only) so that the images now fit the page.

Closes #4682

comment:6 Changed 12 years ago by stuartm

(In [16323]) I made a last minute change to [16322] which wasn't quite correct, this should work as intended.

Refs #4682

Note: See TracTickets for help on using tickets.