Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4707 closed defect (fixed)

AC3 crashes MythFrontend on some DVB-S Channels

Reported by: anonymous Owned by: Janne Grunau
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

hi, check the attached log. My mythfrontend on svn 16138 crashes when wathching recordings from Arte and Sat1 from European Astra Satellite. Other mpeg2 based sound channels work perfectly.

Attachments (2)

ac3crash.log.bz2 (4.4 KB) - added by elkin@… 11 years ago.
Crash log from mythfrontend -v important,most > /home/mythtv/ac3crash.log
iso639.cpp.diff (439 bytes) - added by Wolfgang <mythtv@…> 11 years ago.

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by elkin@…

Attachment: ac3crash.log.bz2 added

Crash log from mythfrontend -v important,most > /home/mythtv/ac3crash.log

comment:1 Changed 11 years ago by Janne Grunau

Priority: criticalminor
Severity: highmedium
Status: newinfoneeded_new
Version: unknownhead

we need a gdb backtrace for the crash.

I could try to reproduce it if I know which shows on arte have AC3 audio. None of my recent arte recordings had ac3 audio.

Changed 11 years ago by Wolfgang <mythtv@…>

Attachment: iso639.cpp.diff added

comment:2 Changed 11 years ago by Wolfgang <mythtv@…>

Maybe this is the same problem I have discovered. The frontend crash in the function iso639_str3_to_key() mpeg/iso639.h The problem is that if no two character string found the function iso639_str3_to_key() mpeg/iso639.cpp: returns Null.

The german channel ard use the language id dd for the dolby digital stream. Maybe the id can be put in the codemap. Ard also uses the 2ch as a language id for joint-stereo.

comment:3 Changed 11 years ago by Janne Grunau

Status: infoneeded_newnew

comment:4 Changed 11 years ago by Janne Grunau

Milestone: unknown0.21
Owner: changed from Isaac Richards to Janne Grunau
Status: newassigned

regression from [16027]

comment:5 Changed 11 years ago by Janne Grunau

Resolution: fixed
Status: assignedclosed

(In [16163]) Fix a segfault in ISO639 language code parsing. Closes #4707.

Found by Wolfgang <mythtv linux-dude de>, fixed differently by me.

comment:6 Changed 11 years ago by Janne Grunau

(In [16164]) Merges revision [16163] from trunk: Fix a segfault in ISO639 language code parsing. Closes #4707.

Found by Wolfgang <mythtv linux-dude de>, fixed differently by me.

Note: See TracTickets for help on using tickets.