Opened 12 years ago

Closed 11 years ago

#4713 closed defect (invalid)

svn revision 15893 causes Xbox mythfrontend to seg fault

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

upgraded from svn 15892 to svn 15893 on xbox and mythfrontend immediately seg faults. mythfrontend -v all does not yield any extra info. Attached is strace file.

Attachments (1)

15893.txt (34.1 KB) - added by anonymous 12 years ago.
xbox mythfrontend svn 15893 strace

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by anonymous

Attachment: 15893.txt added

xbox mythfrontend svn 15893 strace

comment:1 Changed 12 years ago by stuartm

Status: newinfoneeded_new

Did you follow the instructions given in the commit message for 15893?

"You must rerun ./configure and recompile both MythTV and the plugins due to audio ABI changes."

Why did you stop at 15893? Fixes are being applied all the time and we're currently on [16161], did you look to see if a fix had been committed in later revisions?

comment:2 in reply to:  1 Changed 12 years ago by anonymous

Replying to stuartm:

Did you follow the instructions given in the commit message for 15893?

"You must rerun ./configure and recompile both MythTV and the plugins due to audio ABI changes."

Why did you stop at 15893? Fixes are being applied all the time and we're currently on [16161], did you look to see if a fix had been committed in later revisions?

A search for 'xbox' didn't turn anything up past rev 15893 for me. The mythsvn.sh script I'm using to update to svn revs on the xbox and backend does run ./configure with various options. Also, the xbox has mythplugins configured with --disable-all option. Things were working fine at rev 15595, however when I bumped up to the latest svn (rev 16008 at the time), the xbox frontend seg faulted. The problem disappeared with at svn rev 15892 so I figured something in 15893 might be causing the fault. I am re-compiling to 16161 on the xbox at the moment - will be done later today.

comment:3 Changed 12 years ago by stuartm

Milestone: unknown0.21

If it still segfaults with the latest revision, could you attach a backtrace with created with gdb according to the instructions here: http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

comment:4 in reply to:  3 Changed 12 years ago by anonymous

Replying to stuartm:

If it still segfaults with the latest revision, could you attach a backtrace with created with gdb according to the instructions here: http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

Rebuilt to svn rev 16161 and xbox mythfrontend still segfaults. Rebuit with debug option for gdb backtrace however my xbox debian e-image ran of space and failed to build. Doubtful that I can squeeze any more space out of it, in the meantime if I can provide any other helpful info please advise. Thanks.

comment:5 Changed 11 years ago by danielk

Resolution: invalid
Status: infoneeded_newclosed

no info provided for 2 weeks. closing.

Note: See TracTickets for help on using tickets.