Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4720 closed defect (fixed)

Segfault in tv_play.cpp

Reported by: andrei@… Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

See backtrace - somehow activenvp was NULL in TV::HandleTrackAction?. I tried to turn on DVD subtitles when I got it.

An obvious patch is attached, but I think there's a bigger issue somewhere - why was activenvp NULL when the video was already playing?

Attachments (2)

backtrace.txt (752 bytes) - added by andrei@… 12 years ago.
tv_play.patch (417 bytes) - added by andrei@… 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by andrei@…

Attachment: backtrace.txt added

Changed 12 years ago by andrei@…

Attachment: tv_play.patch added

comment:1 Changed 12 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

(In [16352]) Little patch to catch a null, fixes #4720.

comment:2 Changed 12 years ago by Isaac Richards

(In [16364]) Merge r16352 from trunk:

Little patch to catch a null, fixes #4720.

comment:3 Changed 12 years ago by stuartm

This is the second time in a week that I've seen a segfault caused by activenvp being null, again the fix applied for the first one was just to check the pointer but post-0.21 I'll start looking for the root cause.

Note: See TracTickets for help on using tickets.