Opened 12 years ago

Closed 12 years ago

#4727 closed defect (invalid)

RingBuffer takes too long to see data

Reported by: danielk Owned by: danielk
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

For some reason the RingBuffer? is taking 2+ seconds to see data in a locally accessible file. The file is on a NFS share and NFS attribute caching has been disabled.

2008-02-21 13:57:39.780 TV: Attempting to change from None to WatchingPreRecorded
2008-02-21 13:57:39.783 RingBuf(/video/testing/1019021_20080221132449.mpg): OpenFile(/video/testing/1019021_20080221132449.mpg, 12)
2008-02-21 13:57:39.787 RingBuf(/video/testing/1019021_20080221132449.mpg): CalcReadAheadThresh(0 KB)
                         -> threshhold(64 KB) min read(0 KB) blk size(32 KB)
2008-02-21 13:57:40.849 RingBuf(/video/testing/1019021_20080221132449.mpg): Waited 1.0 seconds for data to become available...
2008-02-21 13:57:41.857 RingBuf(/video/testing/1019021_20080221132449.mpg): Waited 2.0 seconds for data to become available...
2008-02-21 13:57:42.320 AFD: Stream #0, has id 0x49 codec id MPEG2VIDEO, type Video, bitrate 18500000 at 0x0x117a250

Change History (3)

comment:1 Changed 12 years ago by danielk

Milestone: unknown0.21
Status: newaccepted
Version: unknownhead

comment:2 Changed 12 years ago by danielk

Milestone: 0.210.22

Can't reproduce this right now...

comment:3 Changed 12 years ago by danielk

Resolution: invalid
Status: acceptedclosed

I haven't seen this again in 3 weeks, I'm assuming there was a transient problem here.

If anyone sees this again, please reopen this ticket.

Note: See TracTickets for help on using tickets.