Opened 12 years ago

Closed 10 years ago

#4731 closed defect (worksforme)

mythcommflag crashed with SIGSEGV

Reported by: david.morris@… Owned by:
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Bug moved upstream from Ubuntu, the package in use it was built against head at the time. Further files at https://bugs.edge.launchpad.net/ubuntu/+source/mythtv/+bug/190787

This crash just happened, and since it's mythcommflag that runs in the background, I'm not sure if it happens immediately on execution.....

ProblemType?: Crash Architecture: amd64 Date: Sun Feb 10 16:02:37 2008 DistroRelease?: Ubuntu 8.04 ExecutablePath?: /usr/bin/mythcommflag NonfreeKernelModules?: nvidia Package: mythtv-backend 0.20.99+trunk15849-0ubuntu2 PackageArchitecture?: amd64 ProcCmdline?: /usr/bin/mythcommflag -j 181 -V 3 ProcCwd?: / ProcEnviron?: PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin Signal: 11 SourcePackage?: mythtv StacktraceTop?:

?? () ?? () ?? () ?? () ?? ()

Title: mythcommflag crashed with SIGSEGV Uname: Linux mythbox 2.6.24-7-generic #1 SMP Thu Feb 7 00:56:31 UTC 2008 x86_64 GNU/Linux UserGroups?: audio cdrom dialout video

Change History (3)

comment:1 Changed 11 years ago by stuartm

Milestone: unknown0.22
Owner: changed from Isaac Richards to stuartm
Status: newaccepted
Version: unknownhead

Think I've traced this to an out of bounds error in VideoBuffers::at()

comment:2 Changed 11 years ago by stuartm

Owner: stuartm deleted
Status: acceptednew

comment:3 Changed 10 years ago by paulh

Resolution: worksforme
Status: newclosed

Going to close this as works for me. It's a very old ticket and a lot has changed which may well have already fixed this. If you can still reproduce using trunk or 0.22 when it's released then please re-open with updated backtraces and logs.

Note: See TracTickets for help on using tickets.