Opened 12 years ago

Closed 11 years ago

#4756 closed defect (worksforme)

Segfault when applying screen setup

Reported by: anonymous Owned by: stuartm
Priority: minor Milestone: 0.22
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When I try to apply settings in the "screen setup" screen mythfrontend always crashes. This happens both when reverting to default values and when applying new screen size. I'm at revision 16208.

I'm attaching gdb backtrace and I will monitor this ticket and answer questions or give more information if needed.

I'm running Slackware 12.0.

Attachments (1)

gdb.txt (7.8 KB) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by anonymous

Attachment: gdb.txt added

comment:1 Changed 12 years ago by stuartm

Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm
Status: newassigned

comment:2 Changed 12 years ago by stuartm

You say that the segfault occurs when you are reverting/saving changes? The backtrace points to the segfault occurring when you 'Escape' from mythappearance which doesn't fit. Is there a chance that you have Escape bound to the same action as Select, or that you are hitting Escape immediately after selecting the menu entries?

comment:3 Changed 12 years ago by anonymous

The crash happens when I select MENU and then selects "Reset screen size settings". I don't hit escape at any point.

comment:4 Changed 12 years ago by stuartm

Milestone: 0.210.22

I can't reproduce this using either painter and I can't find the cause, bumping it to 0.22.

comment:5 Changed 12 years ago by jakep_82@…

I'm running Mythbuntu 8.04 and I see this bug for the OpenGL painter. The QT painter works correctly.

comment:6 Changed 11 years ago by stuartm

Status: assignedstarted

comment:7 Changed 11 years ago by stuartm

Status: startedinfoneeded

Could someone who can reproduce this with current trunk provide an updated backtrace?

comment:8 Changed 11 years ago by rafmoslin@…

Think this may be fixed as I was going to do a backtrace for you but it now works without the segfault with latest trunk (today), menu text placement is messed up on the reload just like when changing themes but otherwise fine. Hope that's of some use and not noise.

comment:9 Changed 11 years ago by stuartm

Resolution: worksforme
Status: infoneededclosed
Note: See TracTickets for help on using tickets.