Opened 12 years ago

Closed 11 years ago

#4767 closed defect (wontfix)

DVD playback doesn't seem to use XvMC_VLD.

Reported by: nigel@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: 0.21-fixes
Severity: medium Keywords: dvd xvmc
Cc: Ticket locked: no

Description

I've upgraded to SVN and have managed to get everything working okay apart from DVD playback. Playback works fine using mplayer, but under MythTV XvMC doesn't seem to be used. I'll attach extracts of my log show DVD playback and watching TV.

Not sure what you count as a blocker, but I'll put the priority as that initially since it stops me from being able to watch DVDs using MythTV.

Attachments (2)

dvd-playback.log (51.3 KB) - added by nigel@… 12 years ago.
Section of the log from attempting DVD playback
tv-playback.log (41.0 KB) - added by nigel@… 12 years ago.
Section of the log from TV playback

Download all attachments as: .zip

Change History (13)

Changed 12 years ago by nigel@…

Attachment: dvd-playback.log added

Section of the log from attempting DVD playback

Changed 12 years ago by nigel@…

Attachment: tv-playback.log added

Section of the log from TV playback

comment:1 Changed 12 years ago by skamithi

Priority: blockerminor
Resolution: wontfix
Status: newclosed

compile your system without opengl rendering support (default in svn head). currently xvmc dvd playback doesn't work if you have opengl support compiled. for viewing dvd menus the system reverts to non-xvmc playback.It should choose Xv renderer. If you have opengl support then it'll try and use the opengl renderer and that doesn't work.

comment:2 Changed 12 years ago by Robin Gilks <g8ecj@…>

Resolution: wontfix
Status: closednew

I've had the problem that on a Via motherboard, xvmc_vld does not work with DVD menus resulting in a very jerky display (just in the menu sequences) for several months now. Looking at this ticket I thought I'd check my opengl config and I have the following output from configure:

# Basic Settings Compile type release Compiler cache yes DistCC no install prefix /usr/local CPU x86_32 (i686) big-endian no MMX enabled yes CMOV enabled yes CMOV is fast yes

# Input Support Joystick menu yes lirc support yes Apple Remote no Video4Linux sup. yes ivtv support yes FireWire? support no DVB support yes usr/include DBox2 support no HDHomeRun support no IPTV support no

# Sound Output Support OSS support yes ALSA support yes aRts support no JACK support no libfftw3 support no

# Video Output Support x11 support yes xrandr support yes xv support yes XvMC support yes XvMC VLD support yes XvMC pro support yes XvMC OpenGL sup. no XvMC libs -lXvMCW OpenGL video no Mac acceleration no OpenGL vsync no DirectFB no Fribidi formatting no

# Misc Features multi threaded libavcodec yes Frontend yes Backend yes

# Bindings bindings_perl yes bindings_python yes

This indicates that there is no opengl support being compiled in. When I run the frontend executable however it reports differently. Which one should I believe?

Please include all output in bug reports. MythTV Version : 16237 MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080224-1 Network Protocol : 40 Options compiled in:

linux release using_oss using_alsa using_backend using_dvb using_frontend using_ivtv using_joystick_menu using_lirc using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads

comment:3 Changed 12 years ago by nigel@…

Hi again.

Thanks for the explanation and workaround. Would you consider changing the target milestone etc rather than closing this as WONTFIX? From what you say, it sounds like you are planning on fixing it (or at least should plan on fixing it!), even if that's not done in the .21 timeframe.

Thanks!

Nigel

comment:4 Changed 12 years ago by nigel@…

Done some more looking at this. I didn't previously notice the other person commenting saying it was only on menus. I can confirm this. From adding debugging to the code, it looks like force_xv is being enabled wrongly; that InDVDMenuOrStillFrame() should only check if we're in a still frame. I modified it so that only InStillFrame?() is checked, and that gives the right result on my Matrix DVD's Roadshow logo animation, but when we then go to the two still frames, it bounces between them. The log shows me that InStillFrame? is 1 most of the time during this period, but momentarily goes 0. If you want to give me help, I'll happily accept it! :) Otherwise I'll keep trying to fix and hopefully be able to give you a pre 0.21 patch to make XvMC support perfect.

comment:5 Changed 12 years ago by Robin Gilks <g8ecj@…>

Could you put a patch on the ticket so I can try out this change on my underpowered Via m/b ?

Cheers

comment:6 Changed 12 years ago by nigel@…

Will do as soon as I sort out it getting stuck on the 2 still frames.

comment:7 Changed 12 years ago by danielk

(In [16425]) Refs #4767. Reverts [16424], VideoOutputNull? isn't using the aligned values. Need to review it and some other VideoOutput? classes before recommitting the fix.

comment:8 Changed 12 years ago by danielk

[16425] should have pointed to #4567, not this ticket.

comment:9 Changed 12 years ago by laga

Nigel (nigel@…),

did you ever get around to making that patch?

comment:10 Changed 12 years ago by nigel@…

Not yet, I'm afraid. Too many other things on my plate. TuxOnIce? hasn't even been getting much attention lately... and on top of that, we purchased a new LCD TV that has a DVD player built in.

Nigel

comment:11 Changed 11 years ago by stuartm

Component: mythtvMythTV - DVD Playback
Resolution: wontfix
Status: newclosed

We are more likely to drop XvMC support than add support for this now.

Note: See TracTickets for help on using tickets.