Opened 12 years ago

Closed 12 years ago

#4778 closed patch (fixed)

Too many PAT/PMTs at start of file

Reported by: Shane Shrybman <gnome42@…> Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

[16135] Introduced BufferedWrite?() in dvbrecorder.cpp which causes a bit of a regression.

The new BufferedWrite?() in dvbrecorder doesn't honour _wait_for_keyframe_option or _first_keyframe < 0. This can result in HandleSingleProgramPAT/PMT writing (or buffering) too many PAT/PMTs to the file at recorder startup.

We only need one PAT and one PMT at the start of the file, not KB's of them. :)

The attached patch addresses this by using DTVRecorder::BufferedWrite?() in DVBRecorder::HandleSingleProgramPAT/PMT.

This patch works for me but needs review and testing in other scenarios.

Attachments (1)

mythtv_dvbrec_bufwrite1.diff (993 bytes) - added by Shane Shrybman <gnome42@…> 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by Shane Shrybman <gnome42@…>

comment:1 Changed 12 years ago by danielk

Milestone: unknown0.21
Owner: changed from Isaac Richards to danielk
Status: newassigned
Version: unknown0.21-fixes

comment:2 Changed 12 years ago by danielk

Resolution: fixed
Status: assignedclosed

(In [16385]) Fixes #4778. Only write PAT/PMT after once we start actually writing the video, to avoid a bunch of duplicates.

Note: See TracTickets for help on using tickets.