Opened 12 years ago

Closed 12 years ago

#4801 closed defect (fixed)

Frontend crash when miniplayer disappears

Reported by: Mike Rice <mikerice1969@…> Owned by: paulh
Priority: minor Milestone: 0.21
Component: mythmusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

To reproduce:

In mythmusic start playing a playlist. Exit, leave music playing. Enter mythgallery: menu, marking.. select all, Random to start a slide show. When new song starts miniplayer pops up.. after 10 seconds when the miniplayer wants to disappear.. crash

It doesn't happen after every song but usually occurs within 10 songs.

Running SVN trunk: 16313

Seems to always occur at this SetText? call. I'll attach a full trace.

Thread 1 (process 2669):
#0  0x00000025 in ?? ()
No symbol table info available.
#1  0x02a41562 in UITextType::SetText (this=0xae6f8db8, text=@0xbfefbe24) at uitypes.cpp:2519
No locals.
#2  0x03dbef5a in MiniPlayer::customEvent (this=0xae6f8fc0, event=0x9d97d70) at miniplayer.cpp:351
        oe = (OutputEvent *) 0x9d97d70
        rs = 10
        time_string = {static null = {static null = <same as static member of an already seen type>, d = 0x9c25418, static shared_null = 0x9c25418}, d = 0xaf2ffe58, static shared_null = 0x9c25418}
        info_string = {static null = {static null = <same as static member of an already seen type>, d = 0x9c25418, static shared_null = 0x9c25418}, d = 0xac009498, static shared_null = 0x9c25418}

Attachments (1)

gdb1.txt (21.0 KB) - added by Mike Rice <mikerice1969@…> 12 years ago.
backtrace

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by Mike Rice <mikerice1969@…>

Attachment: gdb1.txt added

backtrace

comment:1 Changed 12 years ago by Mike Rice <mikerice1969@…>

Just to add... it seems to happen more often (or only?) when Smart shuffle is active.

comment:2 Changed 12 years ago by paulh

(In [16335]) Ignore events if MythMusic's mini player is hidden.

Refs #4801.

comment:3 Changed 12 years ago by paulh

(In [16336]) Ignore events if MythMusic's mini player is hidden.

Refs #4801.

comment:4 Changed 12 years ago by paulh

Milestone: unknown0.21
Owner: changed from Isaac Richards to paulh
Status: newassigned
Version: unknownhead

Mike, Can you please update and see if you still have the problem. I had MythMusic running all afternoon while showing a slide show in MythGallery without any problems so I've had to make a guess at what the problem is based on the backtrace.

comment:5 in reply to:  4 Changed 12 years ago by Mike Rice <mikerice1969@…>

Replying to paulh:

Mike, Can you please update and see if you still have the problem. I had MythMusic running all afternoon while showing a slide show in MythGallery without any problems so I've had to make a guess at what the problem is based on the backtrace.

I ran with your change for a few hours this afternoon with no crashes. I'll try some more tomorrow but I suspect it's fixed.

comment:6 Changed 12 years ago by paulh

Resolution: fixed
Status: assignedclosed

Looks like this was fixed by [16335] and [16336].

Note: See TracTickets for help on using tickets.