Opened 12 years ago

Closed 10 years ago

#4818 closed defect (fixed)

Switching to second recording via embedded doesn't set bookmark in first recording

Reported by: Yeechang Lee <ylee@…> Owned by: shane
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords: bookmark embedded playback osd
Cc: Ticket locked: no

Description

How to reproduce bug:

  • I play recording 1.
  • I play recording 2 via the embedded playback box.
  • I jump back to recording 1 (via JUMPPREV or the embedded or regular playback boxes).

Result: The frontend never created a bookmark when I exited 1, so the previous bookmark (if there is one) for 1 is used instead.

This does not occur if "Jump to Program OSD" is disabled; jumping to recording 2 via the OSD list of recordings does properly set the bookmark for 1.

I am running r16254.

Change History (6)

comment:1 Changed 11 years ago by stuartm

Owner: changed from Isaac Richards to stuartm
Status: newassigned

comment:2 Changed 11 years ago by stuartm

Milestone: unknown0.22
Status: assignedaccepted

comment:3 Changed 10 years ago by sphery <mtdean@…>

Is this a dup of #5910 (which has a patch)?

comment:4 in reply to:  3 Changed 10 years ago by ylee@…

Replying to sphery <mtdean@thirdcontact.com>:

Is this a dup of #5910 (which has a patch)?

Sadly, no; I use your -fixes patch for #5910, and this bug still exists.

(I do see, though, that subsequent JUMPPREVs do properly set the bookmark in both recordings, so it's just recording 1 that's affected, and only the first time. I don't know if your #5910 patch is making the difference here, or if the bug has always behaved this way.)

comment:5 Changed 10 years ago by stuartm

Owner: changed from stuartm to shane
Status: acceptedassigned

Re-assigning to Shane since he's dealt with a similar problem recently.

comment:6 Changed 10 years ago by sphery

Resolution: fixed
Status: assignedclosed

(In [21536]) Fix automatically mark as watched when prompts are enabled and setting bookmarks when using the embedded playback box.

Thanks to Shane S. for factoring out the commonalities and for fixing the bookmarks.

Fixes #5910. Fixes #4818.

Note: See TracTickets for help on using tickets.