Opened 11 years ago

Closed 11 years ago

#4871 closed defect (duplicate)

OpenGL Video Renderer only works once

Reported by: greg Owned by: Isaac Richards
Priority: major Milestone: 0.21
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by greg)

I've had this reported by several users and can reproduce it myself as well.

When enabling the OpenGL Video Renderer playback appears to work fine, however upon starting playback a second time the screen remains black but audio is playing in the background. Restarting the frontend allows it to work again, but only once until another restart.

There is nothing logged to indicate a problem of any sort of problem during the first or subsequent startups however I did notice that the first playback outputs the OpenGL info (from inside OpenGLContext::Create()) but subsequent payback start do not show it as if the start of the debug variable is static accross startups

2008-03-05 13:51:15.937 GLCtx: Created window and context. 2008-03-05 13:51:15.968 GLCtx: GLX Version: 1.3 2008-03-05 13:51:15.969 GLCtx: Direct rendering: Yes 2008-03-05 13:51:15.969 GLCtx: OpenGL vendor : NVIDIA Corporation 2008-03-05 13:51:15.969 GLCtx: OpenGL renderer: GeForce? 6150/PCI/SSE2/3DNOW! 2008-03-05 13:51:15.969 GLCtx: OpenGL version : 2.1.2 NVIDIA 169.07 2008-03-05 13:51:15.969 GLCtx: Max texture size: 4096 x 4096

The main reason I set this to major is that I found that if I restarted and stopped playback several times after 3-4 attempts my X would segfault.

Change History (4)

comment:1 Changed 11 years ago by greg

Description: modified (diff)

oh my god I need to drink less caffeine

Hopefully that was understandable to someone other than just me :)

comment:2 Changed 11 years ago by j.suarez.agapito@…

This issue is very likely to be similar to that of ticket #4526. Are you (or the users who reported) using a dual/quad core processor? I only get this problem when running the OpenGL renderer on a multi core processor machine (AMD64x2 4600 EE). The OpenGL renderer works fine on a single core machine (AMD 64 3500+).

comment:3 in reply to:  2 Changed 11 years ago by harley@…

Replying to j.suarez.agapito@gmail.com:

This issue is very likely to be similar to that of ticket #4526. Are you (or the users who reported) using a dual/quad core processor? I only get this problem when running the OpenGL renderer on a multi core processor machine (AMD64x2 4600 EE). The OpenGL renderer works fine on a single core machine (AMD 64 3500+).

I have this same problem on a AMD 64 3000+ single core machine.

comment:4 Changed 11 years ago by greg

Resolution: duplicate
Status: newclosed

I'm Closing this as a duplicate of #4526

Note: See TracTickets for help on using tickets.