Opened 12 years ago

Closed 12 years ago

#4892 closed defect (fixed)

Win32 segfault when entering Screen Setup Wizards (mythapperance)

Reported by: Jeff Black <jmblack256@…> Owned by: paulh
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords: Win32
Cc: Ticket locked: no

Description

...hopefully not a dupe ticket ;)

myth built using win32-packager.pl (set to head) rebuilt and reproduced on mar-3-2008 running full screen, opengl painter (QT painter segfaults aswell) resolution is set at 1680x1050, but also segfaults at 1024x768.

mythfrontend.exe --> Setup --> Setup --> Screen Setup Wizards (segfault)

Program received signal SIGSEGV, Segmentation fault. 0x00523ba1 in _fu744_ZN11MythContext13verbose_mutexE () at mythappearance.cpp:89 89 m_arrowsize_x = m_topleftarrow->GetArea?().width();

Thread 10 (thread 3872.0x57c): #0 0x7c90eb94 in ntdllLdrAccessResource () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #1 0x7c90e9c0 in ntdllZwWaitForSingleObject () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #2 0x7c8025db in WaitForSingleObjectEx? () from C:\WINDOWS\system32\kernel32.dll No symbol table info available. #3 0x0000058c in ?? () No symbol table info available. #4 0x00000000 in ?? () No symbol table info available.

Thread 6 (thread 3872.0x364): #0 0x7c90eb94 in ntdllLdrAccessResource () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #1 0x7c90e9c0 in ntdllZwWaitForSingleObject () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #2 0x7c8025db in WaitForSingleObjectEx? () from C:\WINDOWS\system32\kernel32.dll No symbol table info available. #3 0x000005cc in ?? () No symbol table info available. #4 0x00000000 in ?? () No symbol table info available.

Thread 5 (thread 3872.0xe08): #0 0x7c90eb94 in ntdllLdrAccessResource () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #1 0x7c90e9c0 in ntdllZwWaitForSingleObject () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #2 0x71a54033 in ?? () from C:\WINDOWS\system32\mswsock.dll No symbol table info available. #3 0x00000624 in ?? () No symbol table info available. #4 0x00000001 in ?? () No symbol table info available. #5 0x0fc0fca8 in ?? () No symbol table info available. #6 0x0fc0fd60 in ?? () No symbol table info available. #7 0x0fc0fe48 in ?? () No symbol table info available. #8 0x0fc0fd50 in ?? () No symbol table info available. #9 0x15075894 in ?? () No symbol table info available. #10 0x01c88101 in ?? () No symbol table info available. #11 0xffffffff in ?? () No symbol table info available. #12 0x7fffffff in ?? () No symbol table info available. #13 0x00253588 in ?? () No symbol table info available. #14 0x00000000 in ?? () No symbol table info available.

Thread 4 (thread 3872.0xb88): #0 0x7c90eb94 in ntdllLdrAccessResource () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #1 0x7c90d85c in ntdllZwDelayExecution () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #2 0x7c8023ed in SleepEx? () from C:\WINDOWS\system32\kernel32.dll No symbol table info available. #3 0x00000000 in ?? () No symbol table info available.

Thread 3 (thread 3872.0x6c8): #0 0x7c90eb94 in ntdllLdrAccessResource () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #1 0x7c90e9c0 in ntdllZwWaitForSingleObject () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #2 0x7c8025db in WaitForSingleObjectEx? () from C:\WINDOWS\system32\kernel32.dll No symbol table info available. #3 0x00000654 in ?? () No symbol table info available. #4 0x00000000 in ?? () No symbol table info available.

Thread 2 (thread 3872.0xb70): #0 0x7c90eb94 in ntdllLdrAccessResource () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #1 0x7c90e31b in ntdllZwRemoveIoCompletion () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #2 0x71a5d609 in WSPStartup () from C:\WINDOWS\system32\mswsock.dll No symbol table info available. #3 0x0000068c in ?? () No symbol table info available. #4 0x0f49ffbc in ?? () No symbol table info available. #5 0x0f49ffb0 in ?? () No symbol table info available. #6 0x0f49ffa4 in ?? () No symbol table info available. #7 0x71a5d650 in WSPStartup () from C:\WINDOWS\system32\mswsock.dll No symbol table info available. #8 0x0022f2b8 in ?? () No symbol table info available. #9 0x7c90ee18 in strchr () from C:\WINDOWS\system32\ntdll.dll No symbol table info available. #10 0x00254900 in ?? () No symbol table info available. #11 0x00000000 in ?? () No symbol table info available.

Thread 1 (thread 3872.0x118): #0 0x00523ba1 in _fu744_ZN11MythContext13verbose_mutexE () at mythappearance.cpp:89

foundtheme = false

#1 0x004014c0 in startAppearWiz () at main.cpp:81

mainStack = (class MythScreenStack? *) 0xf17eb70 mythappearance = (class MythAppearance? *) 0xf14efb0

#2 0x00404a06 in _fu24gContext () at main.cpp:390

sel = {static null = <optimized out>, d = 0x10df5730, static shared_null = <optimized out>}

#3 0x66313d81 in _fu52gContext () at myththemedmenu.cpp:2342

rest = {static null = <optimized out>, d = 0x10df5730, static shared_null = <optimized out>} rest = {static null = <optimized out>, d = 0x10df5730, static shared_null = <optimized out>} strlist = {<QValueList<QString>> = {sh = 0x10dfcde0}, <No data fields>} cardid = 1651330430 rest = {static null = <optimized out>, d = 0x10df5730, static shared_null = <optimized out>} stack = (class MythScreenStack? *) 0x626d4d7e newmenu = (class MythThemedMenu? *) 0x22eb2c rest = {static null = <optimized out>, d = 0xf123958, static shared_null = <optimized out>} pmanager = (MythPluginManager? *) 0x22eb2c rest = {static null = <optimized out>, d = 0x10dfcde0, static shared_null = <optimized out>} pmanager = (MythPluginManager? *) 0x22eb2c rest = {static null = <optimized out>, d = 0x3d0000, static shared_null = <optimized out>}

#4 0x6631117f in MythThemedMenuPrivate::keyHandler (this=0xf034e68, actions=@0x22ed7c, fullexit=true) at myththemedmenu.cpp:2074

it = {node = 0xf19da90} action = {static null = <optimized out>, d = 0xf0bf230, static shared_null = <optimized out>} i = 0 fullexit = true lastbutton = (ThemedButton? *) 0xf0f4950 oldrow = 2 oldcolumn = 0 handled = true

#5 0x66310ab7 in MythThemedMenuPrivate::keyPressHandler (this=0xf034e68, e=0x22f3ac) at myththemedmenu.cpp:1979

actions = {<QValueList<QString>> = {sh = 0x10e005f8}, <No data fields>}

#6 0x6631589f in MythThemedMenu::keyPressEvent (this=0xf150ee0, e=0x22f3ac) at myththemedmenu.cpp:2560

ret = true

#7 0x662d0d66 in MythMainWindow::eventFilter (this=0xf17d008, e=0x22f3ac) at mythmainwindow.cpp:1207

top = (class MythScreenType? *) 0xf150ee0 ke = (QKeyEvent *) 0x22f3ac it = (class MythScreenStack? ) 0xf18abec ge = (class MythGestureEvent? *) 0x22eec8

#8 0x62282d18 in libqt-mt3!_ZN7QObject16activate_filtersEP6QEvent () from C:\mythtv\mythtv\run\libqt-mt3.dll No symbol table info available. #9 0x62282e11 in libqt-mt3!_ZN7QObject5eventEP6QEvent () from C:\mythtv\mythtv\run\libqt-mt3.dll No symbol table info available. #10 0x622d9b00 in libqt-mt3!_ZN7QWidget5eventEP6QEvent () from C:\mythtv\mythtv\run\libqt-mt3.dll No symbol table info available. #11 0x6220d901 in libqt-mt3!_ZN12QApplication14internalNotifyEP7QObjectP6QEvent () from C:\mythtv\mythtv\run\libqt-mt3.dll No symbol table info available. #12 0x622100f2 in libqt-mt3!_ZN12QApplication6notifyEP7QObjectP6QEvent () from C:\mythtv\mythtv\run\libqt-mt3.dll No symbol table info available. #13 0x621c4a07 in libqt-mt3!_ZN9QETWidget12sendKeyEventER6tagMSGN6QEvent4TypeEiiibRK7QStringb () from C:\mythtv\mythtv\run\libqt-mt3.dll No symbol table info available. #14 0x621cba6e in libqt-mt3!_ZN9QETWidget17translateKeyEventE6tagMSGb () from C:\mythtv\mythtv\run\libqt-mt3.dll No symbol table info available. #15 0x621c964b in qt_window_procedure@16 () from C:\mythtv\mythtv\run\libqt-mt3.dll No symbol table info available. #16 0x77d48709 in USER32!GetDC () from C:\WINDOWS\system32\user32.dll No symbol table info available. #17 0x0010065a in ?? () No symbol table info available. #18 0x00000100 in ?? () No symbol table info available. #19 0x00000027 in ?? () No symbol table info available. #20 0x014d0001 in ?? () No symbol table info available. #21 0x621c8c20 in libqt-mt3!_ZN9QETWidget19translateMouseEventERK6tagMSG () from C:\mythtv\mythtv\run\libqt-mt3.dll No symbol table info available. #22 0x77d487eb in USER32!GetDC () from C:\WINDOWS\system32\user32.dll No symbol table info available. #23 0x621c8c20 in libqt-mt3!_ZN9QETWidget19translateMouseEventERK6tagMSG () from C:\mythtv\mythtv\run\libqt-mt3.dll No symbol table info available. #24 0x77d489a5 in USER32!GetWindowLongW () from C:\WINDOWS\system32\user32.dll No symbol table info available. #25 0x00000000 in ?? () No symbol table info available.

Change History (3)

comment:1 Changed 12 years ago by paulh

Milestone: unknown0.21
Owner: changed from Isaac Richards to paulh
Status: newassigned

Looks like it cannot load the appearance window definition from appear-ui.xml for some reason but tries to carry on regardless. It should really bail out if it cannot be found.

comment:2 Changed 12 years ago by paulh

(In [16447]) In MythAppearance? if the window definition cannot be loaded bailout rather than trying to continue and segfault because of missing UI types.

Refs #4892.

comment:3 Changed 12 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [16448]) Merge [16447] from trunk.

In MythAppearance? if the window definition cannot be loaded bailout rather than trying to continue and segfault because of missing UI types.

Fixes #4892.

Note: See TracTickets for help on using tickets.