Opened 12 years ago

Closed 12 years ago

#4898 closed defect (duplicate)

DVD ISO with menu playback broken

Reported by: Bill <level42@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

DVD ISOs with menus do not play. The internal player just stalls, mythfrontend does not die. For some there are no messages in the log, for other there are some error messages but I'm not sure they are related:

invalid mb type in I Frame at get_buffer() failed(stride changed)

The message below for some will continually repeat in the log until I kill it AFD Error: Unknown decoding error [mpeg2video @ 0xb7390908]get_buffer() failed (stride changed)

A few DVD ISOs that I have tried that I ripped only the movie (no menu) seem to play. DVD ISOs with a short movie intro then that go to the menu, play the short movie intro then hang when they are suppose to go to the menu.

This could be related to #4897, but I am running Intel chipsets with Nvidia graphics cards.

My only data points are DVD ISO playback last worked in 15874, but does not work in 16323 or 16463. I've only tried those three SVN versions.

Running SVN 16463 right now.

Change History (4)

comment:1 Changed 12 years ago by Bill <level42@…>

Update. SVN 16323 does work, my mistake.

HAve confirmed that reverting avformat.cpp & .h to 16362 works ok. (also 15323 and 15874). So the problem is somewhere between 16463 and 16362 commits. I'm working to narrow it down.

comment:2 Changed 12 years ago by Bill <level42@…>

Update. Problem is in 16446 changeset: "Merge [16394]:[16445] from release-0-21-fixes to trunk"

SVN 16442 of avformatdecoder.cpp is ok. I'll try avformatdecoder.cpp from the release-0-21-fixes from 16394 to 16445 tonight to figure out which one has broken DVD ISO playback with menus.

comment:3 Changed 12 years ago by skamithi

can you confirm this is not a duplicate of #4897 ?

comment:4 Changed 12 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #4897.

Note: See TracTickets for help on using tickets.