Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#4900 closed defect (fixed)

MythWeather's README does not document its dependency on nice

Reported by: pebender@… Owned by: stuartm
Priority: trivial Milestone: 0.22
Component: mythweather Version: 0.21-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

In its README, MythWeather? documents its dependency on perl and several perl modules. However, when MythWeather? runs its perl scripts, it nices them. However, the README does not document MythWeather?'s dependency on nice.

If the system does not have the 'nice' command, then MythWeather? fails and does not provide any useful error message indicating the reason. I maintain a small frontend only distribution (MiniMyth?). Until now, there has been no need for the 'nice' command so I had not included it. It took looking through the MythWeather? source to realize that MythWeather? requires the 'nice' command.

Change History (4)

comment:1 Changed 13 years ago by stuartm

Resolution: fixed
Status: newclosed

(In [16506]) Add note about nice to the requirements section of the mythweather README. Closes #4900

comment:2 Changed 13 years ago by stuartm

(In [16507]) Add note about nice to the requirements section of the mythweather README. Refs #4900

comment:3 Changed 13 years ago by anonymous

Probably not relevant to MiniMyth?, but mythfilldatabase, mythencode.pl, dvbradioexport.pl and ipodexport.pl also depend on nice or /bin/nice.

comment:4 Changed 13 years ago by stuartm

Milestone: unknown0.22
Note: See TracTickets for help on using tickets.