Opened 12 years ago

Closed 10 years ago

#4902 closed defect (fixed)

DVD submenu do not show properly when using adaptive deinterlacers.

Reported by: Bill <level42@…> Owned by: skamithi
Priority: minor Milestone: 0.22
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Submenu pages - background and buttons - do not show properly. The main menu button and background show properly. But when I select an item that is suppose to show another menu, the background is not updated and the menu buttons do not shown properly. The background of the main menu and button text of the main menu is retained. When one moves the cursor buttons, the button text of the submenu are shown.

This does not affect all DVDs but most that I have. Using DVD ISOs. Same problem with SVN and 0.21 fixes.

Attachments (7)

mythfrontend.log (61.0 KB) - added by geoffp@… 12 years ago.
dvd nav problem @ <= 9:07:27
still_frame_not_shown_4902.diff (8.6 KB) - added by skamithi 12 years ago.
dvdmenu.log (42.9 KB) - added by Bill <level42@…> 12 years ago.
frontend log for family ties season 3
COLDITZ.log.bz2 (6.4 KB) - added by jppoet@… 12 years ago.
IAmLegend.log.bz2 (8.4 KB) - added by jppoet@… 12 years ago.
still_frame_not_shown_4902_v2.diff (8.9 KB) - added by skamithi 12 years ago.
v2. difference between v1 is that it changes location of where cellstart is done. this should take care of jppoet's issue. and also removes a hack in avformatdecoder i had for this issue.
Stargate-Ark.log.bz2 (7.5 KB) - added by jppoet@… 12 years ago.
Stargate: Ark of Truth

Download all attachments as: .zip

Change History (42)

comment:1 Changed 12 years ago by geoffp@…

This is also happening for me as of r16483 in 0.21-fixes.

comment:2 Changed 12 years ago by Bill <level42@…>

I have two frontends running identical SVN 16463, one works, the other does not.

The one that works is a P4-2.4GHz with Nvidia 6200 AGP card with driver 1.0-169.0. The other is a CoreDuo? T2500 2GHz with Nvidia 8400GS PCI-E also with driver 1.0-169.0.

For the same DVD, the P4 displays the submenu (for example episode menu off main menu) properly. The other (T2500), does not display the background of the episode menu, background and button text of the main menu stay for the submenu,button text of the submenu only appears when moving the cursor.

Could this be related to dual-processor of the T2500 compared with the single of the P4? I tried the code compiled on the P4 (--proc-opt) on the T2500, no success.

As mentioned in the dev list, I've tried reverting code (avformat.cpp, NuppelVideoPlayer?.cpp and DVDRingBuffer.cpp) back to 15784 with no luck.

And yes both are running identical OS Ubuntu 7.04, one is a clone of the other.

comment:3 Changed 12 years ago by jppoet@…

I see the same problem. I only just started watching DVDs again recently, so do not know when it started. I am running svn 16542, nVidia binary version 169.09, Fedora 8 on a Core 2 duo.

I will try some other nVidia versions when I get a chance. What is the latest "safe" version of Myth trunk -- or has all of the fore-warned merges not happened yet?

John

comment:4 Changed 12 years ago by Bill <level42@…>

I've tried the newer driver 169.12 also, does not help. Like I said works on a single core with Nvidia 6200. What video card do you have? It may be Nvidia driver related for the newer 8xxx cards or may be related to having two processors.

comment:5 Changed 12 years ago by jppoet@…

I am using a 7300GT.

comment:6 Changed 12 years ago by anonymous

I'm on a single-core CPU + Geforce 5200, and this happens to me on almost every DVD I watch.

On the Entourage DVD I just got from NetFlix?, not only are 3 of 4 sub-menus not displayed (with the previous menu graphic stubbornly remaining, but with button highlights belonging to the sub-menu) but one of the episodes won't even play; it just goes to a black screen and seizes. This happens unless I choose (blindly) the option to watch the episode preview first, which dumps me back out onto the invisible sub-menu (which this time is just black), and then if I choose to play the full episode after having done that, it will play.

I am baffled.

comment:7 Changed 12 years ago by skamithi

Milestone: unknown0.21.1
Owner: changed from Isaac Richards to skamithi
Status: newassigned

i'll borrow entourage sometime soon from netflix and take a look at this.

comment:8 Changed 12 years ago by skamithi

Status: assignedinfoneeded

please upgrade to the latest 0.21 fixes and report your finding.

comment:9 in reply to:  7 Changed 12 years ago by geoffp@…

Replying to skamithi:

i'll borrow entourage sometime soon from netflix and take a look at this.

Excellent, thank you! The disc I was describing is Entourage Season 2 Disc 3.

I'll try to hack the mythtv ebuild to pull the latest 0.21 fixes. I'll report back as soon as I can test.

comment:10 Changed 12 years ago by Bill <level42@…>

Still have the problem with 0.21-fixes.

Here is a list of DVDs I have tried that have the problem Family Ties Season 3 Family Ties Season 2 Best of Friends Season 3 Quantum Leap Season 1 Quantum Leap Season 2 Eagles - Hell Freezes Over

comment:11 Changed 12 years ago by skamithi

Status: infoneededassigned

attach a "mythfrontend -v playback" output from one of the affected dvds. exit the dvd once you see the problem on the screen.

comment:12 Changed 12 years ago by skamithi

Status: assignedinfoneeded

Changed 12 years ago by geoffp@…

Attachment: mythfrontend.log added

dvd nav problem @ <= 9:07:27

comment:13 Changed 12 years ago by geoffp@…

The above attachment is a "mythfrontend -v playback" output produced by an ISO image of Little Miss Sunshine; the problem occurs on the scene selection screen.

comment:14 Changed 12 years ago by geoffp@…

Also, this is still happening for me as of r16807 in 0.21-fixes.

Changed 12 years ago by skamithi

comment:15 Changed 12 years ago by skamithi

Status: infoneededassigned

please test attached patch and report your findings. should apply to both 0.21 fixes and trunk.

comment:16 Changed 12 years ago by geoffp@…

skamithi, your patch appears to fix the problem, at least as observed in Little Miss Sunshine. Highlights seem to appear just before the still does, but that's normal for all I know, and certainly doesn't bother me.

Well done!

comment:17 Changed 12 years ago by skamithi

the button highlight appearing a little before the intended frame is something i hope to fix. its really low on my todo list..so i'm glad you can live with it. i'll wait for bill(level42) to report back. if this patch works for him, i'll commit this patch to fixes and trunk.

comment:18 Changed 12 years ago by Bill <level42@…>

Didn't fix it for me. I've attached a log where I go to the menu that does not display correctly, then move cursor through menu, then exit mythfrontend

Changed 12 years ago by Bill <level42@…>

Attachment: dvdmenu.log added

frontend log for family ties season 3

comment:19 Changed 12 years ago by jppoet@…

Also did not fix it for me. I am attaching two "-v playback" logs. With "I Am Lengend" it draws the main menu okay, and then does not draw the submenu. With Colditz it does not even draw the main menu.

Changed 12 years ago by jppoet@…

Attachment: COLDITZ.log.bz2 added

Changed 12 years ago by jppoet@…

Attachment: IAmLegend.log.bz2 added

Changed 12 years ago by skamithi

v2. difference between v1 is that it changes location of where cellstart is done. this should take care of jppoet's issue. and also removes a hack in avformatdecoder i had for this issue.

comment:20 Changed 12 years ago by skamithi

jppoet and level42.. please test v2 patch and report your findings.

comment:21 Changed 12 years ago by Bill <level42@…>

Works great on my coreduo frontend. Thanks for resolving this one!!

comment:22 Changed 12 years ago by skamithi

(In [16846]) Refs #4902. revert some of [16035] to resolve issues reported by submitter. solution also tested against dvd used in #4173 and it works fine. will commit to fixes soon if no one else reports problems with this changeset.

comment:23 Changed 12 years ago by jppoet@…

v2 did fix the problem for some of my DVDs, but not all.

I am attaching another log, this time for Stargate: Ark of Truth. It draws the main menu just fine, but does not draw the "special features" menu.

Changed 12 years ago by jppoet@…

Attachment: Stargate-Ark.log.bz2 added

Stargate: Ark of Truth

comment:24 Changed 12 years ago by skamithi

(In [16868]) Refs #4902. internal dvd player. make sure the dvd cell restart, after a video codec/resolution change, occurs only in a cell with a one frame.

comment:25 Changed 12 years ago by skamithi

Disabling the 2x deinterlacer for jppoet resolves the issue. There appears to be a bug in NVP where deinterlacing is still enabled even though a progressive frame is detected. i believe there is a ticket open for this, but I can't find it.

comment:26 Changed 12 years ago by Denys Dmytriyenko <denis@…>

Stanley,

Thanks for working on Internal DVD playback! I had problems with progressive titles being deinterlaced, as discussed here:

http://www.gossamer-threads.com/lists/mythtv/dev/318364

I'll try your fixes later tonight or tomorrow and see if it helps with my other Internal DVD player problems...

comment:27 Changed 12 years ago by geoffp@…

For the record, all my testing has been with yadif 2x, also.

comment:28 Changed 12 years ago by skamithi

(In [16908]) Refs #4902. internal dvd player: remove statement that may cause runseekcellstart to run in loops. also remove some code that causes button to appear when it should not.

comment:29 Changed 12 years ago by skamithi

(In [16912]) Refs #4902. internal dvd player: commit [16846] [16868] [16908] from trunk to 0.21 fixes

comment:30 Changed 12 years ago by skamithi

there is a problem displaying still frames when using adaptive deinterlacers (yadif, greedy). this problem was present after [15109]. discussing the issue with markus schulz.

comment:31 Changed 12 years ago by skamithi

Summary: DVD submenu do not show properlyDVD submenu do not show properly when using adaptive deinterlacers.

comment:32 Changed 11 years ago by mythtv@…

I'm confused by the summary of this bug. I seem to be experiencing it, so based on the summary, I disabled all deinterlacing, and found the problem to still occur. Any debugging data I can provide to assist with this?

comment:33 Changed 11 years ago by anonymous

I can confirm this using greedy deinterlacer on 0.21.0-fixes16838 (using mythbuntu).

comment:34 Changed 10 years ago by stuartm

Milestone: 0.21.10.22
Status: assignedinfoneeded

Is this still an issue with trunk?

comment:35 Changed 10 years ago by stuartm

Resolution: fixed
Status: infoneededclosed

No response to request for information after 30 days

Note: See TracTickets for help on using tickets.