Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4908 closed defect (fixed)

Mytharchive: mythburn / growisofs fails if space character in title

Reported by: mikkomyth@… Owned by: paulh
Priority: minor Milestone: 0.22
Component: mytharchive Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If there is a space in title, growisofs fails.

Finished  dvdauthor
Burning ISO image to /dev/hdc
growisofs -dvd-compat  -use-the-force-luke -Z /dev/hdc -dvd-video -V Elokuva: Ladykillers /media/hda2/temppi/work/dvd
Running growisofs to burn DVD
Executing 'genisoimage -dvd-video -V Elokuva: Ladykillers /media/hda2/temppi/work/dvd | builtin_dd of=/dev/hdc obs=32k seek=0'
I: -input-charset not specified, using utf-8 (detected in locale settings)
genisoimage: No such file or directory. Invalid node - 'Ladykillers'.
:-( write failed: Input/output error

Growisofs option -V Title should be between brackets.
-V "Elokuva: Ladykillers"

Change History (7)

comment:1 Changed 12 years ago by paulh

Can you confirm what version you are using. That bug should have been fix about a month ago in [15741].

comment:2 Changed 12 years ago by anonymous

Sorry I have misunderstood totally used version, but used version was mythbuntu trunk build:

mythfrontend version: 0.21.20080224-1 www.mythtv.org

comment:3 Changed 12 years ago by paulh

Resolution: worksforme
Status: newclosed

I cannot reproduce this. Try updating to current svn.

comment:4 Changed 12 years ago by teet.niin@…

I'm having similar issues with mytharchive. Not 100% sure but it seems when recording includes either space or üõöä letter i can't finish archive job. When i try burn actual dvd(not an image) i get bit different error! If it is needed i may post it. For example i tried to create ISO: progress.log 2008-03-18 20:28:42 mythburn.py (0.1.20080127-1) starting up... 2008-03-18 20:28:44 Found 2 CPUs 2008-03-18 20:28:44 Obtaining MythTV settings from MySQL database for hostname KinoPurk? 2008-03-18 20:28:44 temppath: /storage/Archive/tmp/work 2008-03-18 20:28:44 logpath: /storage/Archive/tmp/logs 2008-03-18 20:28:44 Setting process priority to 10 2008-03-18 20:28:44 Processing Mythburn job number 1. 2008-03-18 20:28:44 Options - mediatype = 0, doburn = 0, createiso = 1, erasedvdrw = 1 2008-03-18 20:28:44 savefilename = 2008-03-18 20:28:44 Looking for: /usr/share/mythtv/mytharchive/themes/Simple - Autoplay/theme.xml 2008-03-18 20:28:44 Loading font 0, /usr/share/mythtv/FreeSans.ttf size 23 2008-03-18 20:28:44 Loading font 1, /usr/share/mythtv/FreeSans.ttf size 18 2008-03-18 20:28:44 Loading font 2, /usr/share/mythtv/FreeSans.ttf size 16 2008-03-18 20:28:44 wantIntro: 0, wantMainMenu: 0, wantChapterMenu:0, wantDetailsPage: 0 2008-03-18 20:28:44 Final DVD Video format will be pal 2008-03-18 20:28:44 There are 1 files to process 2008-03-18 20:28:44 Pre-processing file '/storage/TV/Recordings/2002_20080317200000.mpg' of type 'recording' 2008-03-18 20:28:46 VƵsareporter 2008-03-18 20:28:46 Video resolution is 720 by 576 2008-03-18 20:28:46 * 2008-03-18 20:28:46 Processing file /storage/TV/Recordings/2002_20080317200000.mpg of type recording 2008-03-18 20:28:46 * 2008-03-18 20:28:46 File type is 'mpegts' 2008-03-18 20:28:46 Video codec is 'mpeg2video' 2008-03-18 20:28:46 Running mythtranscode --mpeg2 to fix any errors 2008-03-18 20:30:37 Preferred audio languages est and eng 2008-03-18 20:30:37 Video id: 0x1e0, Audio1: [1] 0x1c0 (MP2, N/A), Audio2: [-1] - 0x-1 (N/A, N/A) 2008-03-18 20:30:37 Splitting MPEG stream into audio and video parts 2008-03-18 20:30:37 Running: mythreplex --demux --fix_sync -o /storage/Archive/tmp/work/1/stream -v 224 -a 192 "/storage/Archive/tmp/work/1/newfile.mpg" 2008-03-18 20:32:29 Audio track 1 is in mp2 format - re-encoding to ac3 2008-03-18 20:32:29 Encoding audio to ac3 2008-03-18 20:33:41 * 2008-03-18 20:33:41 Finished processing file /storage/TV/Recordings/2002_20080317200000.mpg 2008-03-18 20:33:41 * 2008-03-18 20:33:41 Creating DVD XML file for dvd author (No Menus) 2008-03-18 20:33:41 Adding item 1 2008-03-18 20:33:41 aspect ratio is: 1.33333 2008-03-18 20:33:41 Fixed length chapters: 00:00:00,00:05:00,00:10:00,00:15:00,00:20:00,00:25:00,00:30:00 2008-03-18 20:33:41 Total size of video files, before multiplexing, is 949 Mbytes, audio is 47 MBytes, menus are 0 MBytes. 2008-03-18 20:33:41 Video will fit onto DVD. 3410.08 MBytes of space remaining on recordable DVD. 2008-03-18 20:33:41 Multiplexing MPEG stream to /storage/Archive/tmp/work/1/final.mpg 2008-03-18 20:33:41 Adding sync offset of 6ms 2008-03-18 20:33:41 Available streams - video and one audio stream 2008-03-18 20:33:41 Multiplex started PID=4948 2008-03-18 20:33:41 Starting dvdauthor 2008-03-18 20:35:13 Finished dvdauthor 2008-03-18 20:35:14 Creating ISO image 2008-03-18 20:35:14 2008-03-18 20:35:14 ERROR: Failed while running mkisofs. 2008-03-18 20:35:14 2008-03-18 20:35:14 2008-03-18 20:35:14 Terminated

End of mythburn.log(full log is pretty long).

INFO: Generating VMGM with the following video attributes: INFO: MPEG version: mpeg2 INFO: TV standard: pal INFO: Aspect ratio: 4:3 INFO: Resolution: 720x576 INFO: Audio ch 0 format: ac3/2ch, 48khz drc

STAT: fixed 2 VOBUS Finished dvdauthor Creating ISO image ERROR: Failed while running mkisofs.

Terminated

comment:5 Changed 12 years ago by herbert@…

Resolution: worksforme
Status: closednew

This error still occurs when writeing to dvd+-rw and erasing the old contents.

comment:6 Changed 12 years ago by paulh

Resolution: fixed
Status: newclosed

(In [16782]) A couple of MythArchive? fixes.

  • Fix creating a DVD when the first title, which is used to create the DVD's volumeid, has non ascii characters in it.
  • Fix comment not terminated error from dvdauthor caused by titles with a double '-' character in the title.

Fixes #4987, #4908, #5005.

comment:7 Changed 12 years ago by paulh

(In [16783]) Merge r16782 from trunk :-

A couple of MythArchive? fixes.

  • Fix creating a DVD when the first title, which is used to create the DVD's volumeid, has non ascii characters in it.
  • Fix comment not terminated error from dvdauthor caused by titles with a double '-' character in the title.

Refs #4987, #4908, #5005.

Note: See TracTickets for help on using tickets.