Opened 14 years ago

Closed 14 years ago

#491 closed defect (worksforme)

Frontend only build fails

Reported by: jgmtfia@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords: backend vtable undefined reference
Cc: Ticket locked: no

Description

When ./configure is done with --disable-backend, the resulting build fails:

make[2]: Entering directory `/usr/src/other/myth/trunk/mythtv/programs/mythtv'
g++  -o mythtv main.o    -L/usr/share/qt3/lib -L../../libs/libmyth -L../../libs/libmythtv -L../../libs/libavutil -L../../libs/libavcodec -L../../libs/libavformat -lmythtv-0.18 -lmythavformat-0.18 -lmythavutil-0.18 -lmythavcodec-0.18 -lmyth-0.18 -lfreetype -lmp3lame -lasound -L/usr/X11R6/lib -lXinerama -lXv -lXxf86vm -lqt-mt -lXext -lX11 -lm -lpthread
/usr/bin/ld: warning: libstdc++.so.5, needed by /usr/share/qt3/lib/libqt-mt.so, may conflict with libstdc++.so.6
../../libs/libmythtv/libmythtv-0.18.so: undefined reference to `vtable for DVBTransportsEditor'
../../libs/libmythtv/libmythtv-0.18.so: undefined reference to `DVBTransportsEditor::DVBTransportsEditor()'
../../libs/libmythtv/libmythtv-0.18.so: undefined reference to `DVBTransportsEditor::exec()'
../../libs/libmythtv/libmythtv-0.18.so: undefined reference to `VTT for DVBTransportsEditor'
collect2: ld returned 1 exit status

Change History (3)

comment:1 Changed 14 years ago by kstuard (comcast.net)

You have the version set to 0.18.1, yet the --disable-backend didn't come around until after 0.18.2.

Other than that, what happens when you run it with --disable-dvb?

comment:2 Changed 14 years ago by jgmtfia@…

Version: 0.18.1head

comment:3 Changed 14 years ago by danielk

Resolution: worksforme
Status: newclosed

I can't reproduce this.

Perhaps you just need to do a make distclean? Perhaps you are linking to an old MythTV? Try removing any pre-existing MythTV installs before compling.

If this is on a Mac OS X machine, try this with the latest SVN and if it still fails reassign the ticket to Nigel.

This is a porting option so it is only supported on OS X.

Note: See TracTickets for help on using tickets.