Opened 12 years ago

Closed 12 years ago

#4915 closed defect (duplicate)

ofdb.py: try harder to find movie ID

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

ofdb.py sometimes will not return a movie id although the website is clearly returning search hits. It seems that for some search terms, the web site containing the search results uses a different path to point to the detail page for that movie. It's easy to work around that because ofdb.de just uses HTTP 301 redirects to point to the correct address.

Here's an example with the new URL format:

{{{./ofdb.py -r -M 'wutprobe' | grep 'Wutprobe'

<b>Deutscher Titel:</b><br><br>1. <a href="view.php?page=film&fid=33867" onmouseover="Tip('<img src=&quot;images/film/33/33867.jpg&quot; width=&quot;120&quot; height=&quot;180&quot;>',SHADOW,true)">Wutprobe, Die<font size="1"> / Anger Management</font> (2003)</a><br><br><br></font></p><br> }}}

Here's the old format:

./ofdb.py -r -M 'die wutprobe' | grep 'Wutprobe'

<b>Deutscher Titel:</b><br><br>1. <a href="film/33867,Die-Wutprobe" onmouseover="Tip('<img src=&quot;images/film/33/33867.jpg&quot; width=&quot;120&quot; height=&quot;180&quot;>',SHADOW,true)">Wutprobe, Die<font size="1"> / Anger Management</font> (2003)</a><br><br><br></font></p><br>

It's really odd because the search terms don't differ much and actually point to the same movies. Anyways, the attached patch fixes this.

Change History (1)

comment:1 Changed 12 years ago by Janne Grunau

Resolution: duplicate
Status: newclosed

duplicate of #4916

Note: See TracTickets for help on using tickets.