Opened 12 years ago

Closed 9 years ago

#4920 closed defect (Invalid)

UPNP with DirecTV HR-21 Broken

Reported by: jeff@… Owned by: beirdo
Priority: minor Milestone: unknown
Component: MythTV - UPnP Version: Master Head
Severity: medium Keywords: upnp
Cc: Ticket locked: no

Description

The HR-21 seems to communicate fine with MythTV. It lists out all the recordings on the MythTV system just fine, however, when you go to play the video file, the HR-21 claims it cannot access the video files.

If I set the "VideoRoot?" directory for MythVideo? to be the same as the directory that MythTV records TV shows to, the HR-21 plays the movie files just fine.

Attached is a "tcpdump" output of a failed attempt to play a video file off of MythTV. Also attached is the mythbackend log of the same attempt. Mythbackend is running with "-v upnp" running.

Attachments (3)

upnp.pcap (105.5 KB) - added by jeff@… 12 years ago.
tcpdump of failed attempt to play a recording via UPNP.
upnp.log (11.3 KB) - added by jeff@… 12 years ago.
Mythbackend log file of problem with "-v upnp" option active.
upnp.patch (1.3 KB) - added by jeff@… 12 years ago.
Patch to fix issue with escaping characters in UPNP responses.

Download all attachments as: .zip

Change History (16)

Changed 12 years ago by jeff@…

Attachment: upnp.pcap added

tcpdump of failed attempt to play a recording via UPNP.

Changed 12 years ago by jeff@…

Attachment: upnp.log added

Mythbackend log file of problem with "-v upnp" option active.

Changed 12 years ago by jeff@…

Attachment: upnp.patch added

Patch to fix issue with escaping characters in UPNP responses.

comment:1 Changed 12 years ago by jeff@…

I added a patch to fix an issue I found in regards to this problem. I was seeing this quite often in the debugging output from Mythbackend:

2008-06-07 14:35:48.531 HTTPRequest::Encode Input : RecTv?/0/item?ChanId?=1249&StartTime?=2008-04-23T22:00:00 2008-06-07 14:35:48.536 HTTPRequest::Encode Output : RecTv?/0/item?ChanId?=1249&StartTime?=2008-04-23T22:00:00 2008-06-07 14:35:48.622 HTTPRequest::Encode Input : RecTv?/1/key=South Park/item?ChanId?=1249&StartTime?=2008-04-16T22:00:00 2008-06-07 14:35:48.626 HTTPRequest::Encode Output : RecTv?/1/key=South Park/item?ChanId?=1249&StartTime?=2008-04-16T22:00:00 2008-06-07 14:35:48.650 HTTPRequest::Encode Input : RecTv?/0/item?ChanId?=1249&StartTime?=2008-04-16T22:00:00 2008-06-07 14:35:48.654 HTTPRequest::Encode Output : RecTv?/0/item?ChanId?=1249&StartTime?=2008-04-16T22:00:00

It seems like the HTTPRequest::Encode routing is getting called multiple times for the same string, and because of this, the ampersand in the escaped output was getting re-escaped.

This did not entirely fix the DirecTV HR20/21 issue, but at least the receiver is trying to make a connection back to MythTV. It seems to me that problems regarding the DirecTV receiver are due to the fact the the DirecTV HR20/21 will not pass back the HTTP GET variables when it makes the query back to MythTV. With that in mind, it sounds like that is a DirecTV problem.

This patch was made against MythTV 0.21p17416.

comment:2 in reply to:  1 Changed 12 years ago by anonymous

As a side note, MythVideo? seems to work fine with the DirecTV HR20/21, but that's because it doesn't seem to need GET variables to query data.

comment:3 Changed 11 years ago by Dibblah

Status: newassigned

comment:4 Changed 10 years ago by stuartm

Component: upnpMythTV - UPnP

comment:5 Changed 10 years ago by robertm

David, any thoughts on this (apparently simple) escaping fix? I am happy to apply and test. (though not in that order ;) )

comment:6 Changed 10 years ago by robertm

Thanks for mike dean for pointing out that this is a dupe of #5435. It is, however, still evidently a problem in that by breaking one, you fix the other.

comment:7 Changed 10 years ago by sphery

comment:8 Changed 10 years ago by stuartm

Version: 0.21-fixesTrunk Head

Still apparently an issue with trunk

comment:9 Changed 10 years ago by beirdo

Cc: beirdo added

Adding myself as a CC. Maybe I may take a look at this

comment:10 Changed 10 years ago by beirdo

Owner: changed from dblain to beirdo

comment:11 Changed 10 years ago by beirdo

Status: assignedinfoneeded

Please retest this with current trunk.

comment:12 Changed 10 years ago by beirdo

Cc: beirdo removed

comment:13 Changed 9 years ago by robertm

Resolution: Invalid
Status: infoneededclosed

No response in 5 weeks

Note: See TracTickets for help on using tickets.