Opened 12 years ago

Closed 11 years ago

#4926 closed patch (duplicate)

MythTV.pm always prints an error if Net::UPnP::ControlPoint is not installed.

Reported by: andrew@… Owned by: xris
Priority: minor Milestone: unknown
Component: perl / nuvexport Version: 0.21-fixes
Severity: medium Keywords:
Cc: Rob Smith Ticket locked: no

Description

Some of my mythtv-status users have asked about an error message that is always printed from MythTV.pm which says:

Net::UPnP::ControlPoint? is not installed!

Looking at the code this is always printed if Net::UPnP is not installed, even if UPnP isn't needed to be used. Then if MythTV.pm does try and fall back to UPnP but the module isn't present *another* warning is printed.

So I think this first warning isn't required. The attached patch removes it.

If this could go on 0.21-fixes that would be excllent. As it affects anyone using the Perl bindings included with 0.21 that don't have this often unrequired module installed.

Attachments (1)

0001-Don-t-bother-printing-an-error-if-Net-UPnP-Control.patch (782 bytes) - added by andrew@… 12 years ago.

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by andrew@…

comment:1 Changed 12 years ago by sphery <mtdean@…>

This is fixed properly by #4754. #4754 can be applied to both 0.21-fixes and trunk.

comment:2 Changed 12 years ago by anonymous

Actually, that patch fixes another problem. The print STDERR is still not required (which is what my patch removes).

comment:3 Changed 12 years ago by andrew@…

(That last comment was from me)

comment:4 Changed 12 years ago by anonymous

i FOUND THE ERROR!!!!

its not just the Net::UPnP::ControlPoint? that isnt installed. but ALSO Net::UPnP::QueryResponse?

use "cpan" in a terminal and follow its prompts... then when its done with the configuration type this in the cpan prompt "install Perl Net::UPnP::ControlPoint?" and dont forget "cpan> install Net::UPnP::QueryResponse?"

then you should be able to run mythrename.pl or anything else giving the above error. example syntax for mythrename.pl is: /usr/share/mythtv/contrib/mythrename.pl --link /mnt/storage/RaidShare/Movies\ and\ Video/MYTHTVshows/ --format %T/%T%-%S

luv MediAWakE

comment:5 Changed 12 years ago by andrew@…

While that stops the message appearing for you, I still think the message doesn't need to displayed unless UPnP actually fails because the module isn't present.

As it is, I've also been told that MythTV.pm will print out a message on STDERR if it actually wants to use UPnP to find the backend. This is a pain for people trying to use the module as well.

comment:6 Changed 12 years ago by Rob Smith

Cc: Rob Smith added

comment:7 Changed 12 years ago by Rob Smith

I can confirm that the install of Net::UPnP::QueryResponse fixes the Net::UPnP::ControlPoint message

comment:8 Changed 12 years ago by andrew@…

Excellent. But apply my patch will also fix the problem since UPnP isn't required for this module to work.

comment:9 Changed 11 years ago by Dibblah

Status: newassigned

comment:10 Changed 11 years ago by xris

Resolution: duplicate
Status: assignedclosed

Dupe of #4754

Note: See TracTickets for help on using tickets.