Opened 12 years ago

Closed 10 years ago

#4943 closed defect (fixed)

Internal Player Can't Handle Mpeg2 that mplayer can.

Reported by: km@… Owned by: Janne Grunau
Priority: trivial Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mpeg2 HD Program Streams from a Direct Tivo do not play properly in the internal player, but are fine in mplayer/xine/vlc.

The playback in the internal player gives constant

NVP: Video is 30 frames behind audio (too slow), dropping frame to catch up.

I will attach a log gotten from playing a 5 second 10MB sample.

I would like to attach the sample, but my guess is that 10MB is too big. If I fail to attach it, I will make it available for a time as

http://www.mathcs.emory.edu/~km/test.mpg

I'm running a few day old svn, but this has shown for a long time.

Attachments (2)

log (33.5 KB) - added by km@… 12 years ago.
logfile from internal player
log.2 (232.1 KB) - added by km@… 12 years ago.
log for 250MB sample

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by km@…

Attachment: log added

logfile from internal player

comment:1 Changed 12 years ago by stuartm

Status: newinfoneeded_new

"Few days old svn" is probably too old, playback fixes have been hitting trunk almost daily in the run up to 0.21 and one or two have also been committed since then. Neither Greg or I have any problems playing the sample provided with current SVN.

Could you upgrade and try again?

comment:2 Changed 12 years ago by skamithi

Status: infoneeded_newnew

if the problem is present after you upgrade, set the audio device to null.( "Setup->General->Audio"), to see if this some type of audio problem either with mythtv or with your setting.

comment:3 Changed 12 years ago by skamithi

Status: newinfoneeded_new

comment:4 Changed 12 years ago by km@…

Well much to my surprise doing an svn update did fix it. Really, I had been seeing this for months, and it continued through an update maybe a week old.

Before doing the update, I did try running with audio null, and the video was smooth. After the update the video is smooth with audio.

Before the update I was getting

NVP: Video is 30 frames behind audio (too slow), dropping frame to catch up

After the udpate, its the other way

NVP: Video is 3.22799 frames ahead of audio, doubling video frame interval to slow down

I guess this can be closed.

comment:5 Changed 12 years ago by Janne Grunau

Milestone: unknown0.22
Priority: minortrivial
Status: infoneeded_newnew

no, it shouldn't be closed there might be an error in the timestamp calculation. Playback is fixed since I committed a workaround.

comment:6 Changed 12 years ago by Janne Grunau

Owner: changed from Isaac Richards to Janne Grunau
Status: newaccepted

Changed 12 years ago by km@…

Attachment: log.2 added

log for 250MB sample

comment:7 Changed 11 years ago by km@…

There hasn't been any apparent action on this bug in 4 months. I am the original reporter, and I may have caused some confusion. I originally thought the bug was fixed when I updated to a newer svn. In fact the only thing that changed is how long it takes for the bug to show in the video. Originally, I had an example that only took a few seconds. The smallest example I have now is 250MB and that is available as

http://www.mathcs.emory.edu/~km/test.mpg

This still occurs in svn as of 6/30/2008.

The problem actually occurs with most any mpeg2 extracted from an HD Directv Tivo. Once again, the other media players (vlc, mplayer, xine) don't have the problem.

I think its more serious than the current "trivial" priority. If there is any more info I can provide please let me know.

comment:8 Changed 11 years ago by Loki

FYI this topic has been discussed on the developers mailinglist several times and the last time I checked someone was working on it.

comment:9 Changed 10 years ago by Janne Grunau

Resolution: fixed
Status: acceptedclosed

seems to be fixed in current trunk, reopen if not

Note: See TracTickets for help on using tickets.