Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4987 closed patch (fixed)

Volume ID string too long

Reported by: mr.bienzle@… Owned by: paulh
Priority: minor Milestone: unknown
Component: mytharchive Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This bug occurs, if the title of the recording is longer than 32 and contains a german "Umlaut" within the first 32 bytes. One will get the following error while exporting the recording to DVD by creating an iso Image:

Creating ISO image
genisoimage: Volume ID string too long
************************************************************
ERROR: Failed while running mkisofs.
************************************************************

Terminated

An example title to reproduce the bug is "Disneys Aladdin und der König der Diebe"

This happens because the german "Umlaut" is not encoded correct. I found the problem on a Debian GNU/Linux System running mythtv 0.21 "stable" version. My locale is "en_US.UTF-8".

A patch for mythburn.py script is attached to this ticket.

Could you please apply it to svn? The patch applies to the file "mythplugins-0.21/mytharchive/mythburn/scripts/mythburn.py" in version "0.1.20080127-1"

Attachments (1)

mythburn.py.patch (476 bytes) - added by mr.bienzle@… 12 years ago.
Patch for Ticket #4987

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by mr.bienzle@…

Attachment: mythburn.py.patch added

Patch for Ticket #4987

comment:1 Changed 12 years ago by paulh

Resolution: fixed
Status: newclosed

(In [16782]) A couple of MythArchive? fixes.

  • Fix creating a DVD when the first title, which is used to create the DVD's volumeid, has non ascii characters in it.
  • Fix comment not terminated error from dvdauthor caused by titles with a double '-' character in the title.

Fixes #4987, #4908, #5005.

comment:2 Changed 12 years ago by paulh

(In [16783]) Merge r16782 from trunk :-

A couple of MythArchive? fixes.

  • Fix creating a DVD when the first title, which is used to create the DVD's volumeid, has non ascii characters in it.
  • Fix comment not terminated error from dvdauthor caused by titles with a double '-' character in the title.

Refs #4987, #4908, #5005.

Note: See TracTickets for help on using tickets.