Opened 14 years ago

Closed 14 years ago

#500 closed defect (fixed)

"Aspect Override" broken somehow

Reported by: Oscar Carlsson Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords: aspect override
Cc: Oscar Carlsson Ticket locked: no

Description

Can't really figure this one out, but previously I've had it set to override to 16/9 since I've got a 1024x768 16/9 display. This worked okay (except the fact that it just scales up the picture instead of trying to make it look good with different scaling across the picture like the TV does. Wonder if there's an algorithm out there to do that..).

However, now it behaves odd. With a Aspect Override of None, 4/3 or 16/9 just gives me the same result, 4/3 picture with borders on the sides. If it's set to 16/9 I can just reselect this mode from the menu and it's back to filling the whole screen.

On the other hand, with "16/9 stretch", it fills the whole screen but stretches the video even more if I reselect the mode.. The OSD is also misplaced and scaled wrongly..

Let me know if you need any more information.

Change History (8)

comment:1 Changed 14 years ago by danielk

Have you tried setting the Display size in the monitor section of your xorg.conf file?

Section "Monitor"
   DisplaySize  521 324 # in millimeters
   #other stuff
EndSection

The AspectOverride? overides the aspect ratio of the _video_ stream, it does not adjust the _display_ aspect ratio. X11 assumes you have square pixels unless the monitor itself reports otherwise, or you tell it otherwise with the DisplaySize? setting.

But it does seem like there is something wrong with your letterbox modes. See if you can still reproduce this after setting the display aspect ratio.

BTW If you MythTV's XRandR or Xinerama support, you should set the aspect ratio in the configs for those instead, X server doesn't tell MythTV about the display size correctly in those cases.

comment:2 Changed 14 years ago by Oscar Carlsson

Not using XRandR or Xinerama, and my DisplaySize? is set, MythFrontend reports this:

{{{2005-10-20 15:33:32.356 Window pixel dimensions: 1024x768 Screen pixel dimensions: 1024x768 2005-10-20 15:33:32.356 Estimated display dimensions 342x193 mm. Aspect: 1.77202 2005-10-20 15:33:32.356 Estimated window dimensions 342x193 mm. Aspect: 1.77202}}}

comment:3 Changed 14 years ago by danielk

Hmm, the display aspect ratio values look ok.

I can't reproduce the stretch problem either.

But I can reproduce the problem with Letterbox modes messing things up.

Do we actually need any letterbox modes other than zoom?

Does anyone actually transmit streams with the wrong aspect ratio set?

comment:4 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [7553]) Fixes #500.

Adjust Picture-in-Picture dimensions and location so that it works with the various letterboxing modes.

Tested with 16:9 video embedded in a 4:3 video, and 4:3 video embedded in a 16:9 video.

This does not apply the letterboxing to the PiP video, but plays it back as if it were in the letterbox_Off mode. So the video has to report the correct aspect ratio and MythTV needs to know your displays aspect ratio for it to be played back with the correct aspect ratio.

comment:5 Changed 14 years ago by Oscar Carlsson

Cc: Oscar Carlsson added
Resolution: fixed
Status: closedreopened

Changeset [7553] didn't help, this isn't related to PiP.

If you'd like, I can get photos of the different scenarios if that would help to explain things.

Since I'm not using DVB I don't know about wrongly reported aspect ratios, but I know people have been talking about them before (English channels I think). However, I think it would be alot easier to use the different aspect modes if they where based on your screen ratio, only display appropriate modes suitable for the displpaytype.

Would a "-v playback" help?

comment:6 Changed 14 years ago by danielk

Hmm, I think I misdiagnosed your problem, I thought you wanted to watch content with the correct aspect ratio and MythTV was somehow getting in the way. But now I think I understand.

You are watching 4/3 content on a 16/9 screen, and you want to make the video to fill the 16/9 screen with no borders, so you set the aspect ratio override to 16/9. Instead of filling the screen, by using a 16/9 aspect ratio, it uses the correct aspect ratio for the video resulting in borders...

Try SVN in a few minutes...

comment:7 Changed 14 years ago by danielk

(In [7560]) References #500.

Possible fix.

comment:8 Changed 14 years ago by Oscar Carlsson

Resolution: fixed
Status: reopenedclosed

[7560] seems to have fixed the issue.

Another resolution I just thought about is the ability to set the IVTV driver to deliver 16:9 instead, but now both ways work.

Note: See TracTickets for help on using tickets.