Opened 12 years ago

Closed 12 years ago

#5010 closed defect (worksforme)

Win32 build error in audiooutputdigitalencoder.cpp

Reported by: Nigel Owned by: danielk
Priority: minor Milestone: unknown
Component: windows Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Latest (0.21 - [16733]) win32-packager.pl, r15699 source code.

make[2]: Entering directory `/C/mythtv/mythtv/libs/libmyth'
Makefile:279: warning: overriding commands for target `.'
Makefile:276: warning: ignoring old commands for target `.'
g++ -Wl,-enable-auto-import -mthreads -Wl,-subsystem,windows -shared -Wl,--export-all-symbols -o libmyth-0.22.dll object_ld_script objmoc_ld_script -L"/qt-3.3.x-p8\lib" -L"../libmythsamplerate" -L"../libmythsoundtouch" -L"../libmythui" -L"../libmythupnp" -L"../libmythfreesurround" -L"../libavcodec" -L"../libavutil" -L"." -lqtmain -lmythsamplerate-0.22 -lmythsoundtouch-0.22 -lmythfreesurround-0.22 -lmythavcodec-0.22 -lmythavutil-0.22 -lpthread -lmythui-bootstrap -lmythupnp-bootstrap -lqt-mt -lkernel32 -luser32 -lgdi32 -lcomdlg32 -ladvapi32 -lshell32 -lole32 -loleaut32 -luuid -limm32 -lwinmm -lws2_32 -lwinspool
./audiooutputdigitalencoder.o: In function `Z12encode_framebPhRj':
c:/mythtv/mythtv/libs/libmyth/audiooutputdigitalencoder.cpp:288: undefined reference to `ac3_sync'
collect2: ld returned 1 exit status
make[2]: *** [libmyth-0.22.dll] Error 1
make[2]: Leaving directory `/C/mythtv/mythtv/libs/libmyth'
make[1]: *** [sub-libmyth] Error 2
make[1]: Leaving directory `/C/mythtv/mythtv/libs'
make: *** [sub-libs] Error 2
EFFECT FAILED (newer -> shell): mtime of file (C:/mythtv/mythtv/libs/libmyth/libmyth-0.21.dll) should be greater than file (C:/mythtv/mythtv/last_build.txt)

The weird thing is that I thought this same source tree built last week!

Change History (5)

comment:1 Changed 12 years ago by danielk

Component: mythtvwindows
Owner: changed from Isaac Richards to danielk

comment:2 Changed 12 years ago by Jay Modi <jaymode@…>

I believe this bug is caused by the patches applied by the new version of the script. These patches were tested against r16167 but most likely not r15699. I am currently re-running this script to double check, but I built the entire toolchain yesterday and confirmed everything was working.

comment:3 Changed 12 years ago by andrei@…

Are you sure "make clean" or "rm *.o" in libmyth or libavcodec (where ac3_sync was recently made non-static) wouldn't solve this?

comment:4 Changed 12 years ago by Jay Modi <jaymode@…>

I can confirm the script and patches compile r16167 successfully.

comment:5 Changed 12 years ago by Nigel

Resolution: worksforme
Status: newclosed

After a few swaps between SVN head, 15699 and 16167 which built OK, it seems to be a non-issue. Sorry for the alarm

Note: See TracTickets for help on using tickets.