Opened 11 years ago

Closed 11 years ago

#5025 closed defect (fixed)

Incorrect video profile setting selected for Live TV

Reported by: matt.doran@… Owned by: Janne Grunau
Priority: major Milestone: unknown
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When using Live TV the incorrect video settings are selected, because the dummy video resolution is used for the selection.

The full details including a "playback" log is explained below.

I changed my video profile setup to the "High Quality" profile, which uses yadif(x2) for SD content, and reverts back to linearblend for HD (>= 1920x1080).

When I use this profile, it works as expected for SD content, choosing the profile for SD content with the yadif(x2).

However when I view a HD channel with LiveTV, it chooses the wrong profile (or at least the wrong deinterlacer). I believe this has something to do with the "dummy video" that it sets up which has a resolution of 720x576 while waiting for the channel to tune.

I've attached some verbose "playback" logging showing the problem.

In summary:

  • You can see I have a >= 1920x1080 profile that uses linear blend (line 10)
  • It seems to start initialising video at resolution 720x576 (line 29)
  • Myth picks the video profile based on this dummy resolution (line 40)
  • The yadif interlacer is initialized with resolution 720x576 (lines 85 and 86)
  • Once the tuner locks onto the HD channel, the video comes in at

1920x1088 resolution (line 178)

  • The Yadif deinterlacer recognizes the change in video resolution

(line 180)

  • Video cannot be displayed properly because yadif(x2) requires too much processing power for HD (lines 231-239).

If I watch a previously recorded show it works as expected, because it starts playing the content that is 1920x1080 resolution ... so that it sets up the profile correctly. This problem only seems to appear when using live TV which initially sets up the dummy 720x576 stream.

Attachments (2)

live-tv-playback.log (20.4 KB) - added by matt.doran@… 11 years ago.
Playback log starting LiveTV with HD channel
patch.diff (643 bytes) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by matt.doran@…

Attachment: live-tv-playback.log added

Playback log starting LiveTV with HD channel

comment:1 Changed 11 years ago by ylee@…

I, too, have noticed this exact bug. My video profile has three filters, one which triggers on 720x576 and below. Like Matt, I initially set this filter to use Yadif (2x) because my frontend is powerful enough to use that deinterlacer on SD-resolution programs (but not larger ones). Because of the dummy video in Live TV I've changed it to use Bob as the other filters do until the bug is fixed.

comment:2 Changed 11 years ago by anonymous

confirmed - I am experiencing this exact problem.

comment:3 Changed 11 years ago by david.madsen@…

Also confirmed here. I may take a shot at fixing this, though I'm by no means an expert with the MythTV code.

Changed 11 years ago by anonymous

Attachment: patch.diff added

comment:4 Changed 11 years ago by anonymous

I've added a patch that has worked for me on 0.21-fixes. The VideoOutput? class needs to setup the correct deinterlacer when the input has changed.

comment:5 Changed 11 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:6 Changed 11 years ago by Janne Grunau

Owner: changed from danielk to Janne Grunau
Status: assignedstarted

[18114] should have referenced this ticket

comment:7 Changed 11 years ago by Janne Grunau

Resolution: fixed
Status: startedclosed

(In [18116]) ibackports [18114] from trunk, reset deinterlacer after input change

Fixes #5025

Note: See TracTickets for help on using tickets.