Opened 14 years ago

Closed 14 years ago

#507 closed defect (fixed)

"Full scan of existing transports"

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.19
Component: dvb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I can scan fine when doing doing an existing transport scan and moving though each transport manually, but the Full Scan of Existing Transports times out on each transport.

The signal timeout value seems to make no difference and it doesn't seem relevant if it can scan a single transport fine but not sequentially.

The card is a Leadtek LR6650 and I'm in the UK.

I will do what I can to help debug the problem.

Attachments (3)

ex_transport.log (8.8 KB) - added by anonymous 14 years ago.
full_scan_ex_transports.log (14.3 KB) - added by anonymous 14 years ago.
siparser_timeout_check.patch (538 bytes) - added by danielk 14 years ago.
possible fix

Download all attachments as: .zip

Change History (9)

comment:1 Changed 14 years ago by danielk

Status: newassigned

Can you attach the log from "mythtv-setup -v channel,siparser" for one Existing Transport, and another log from a Full Scan of Existing Transports?

Changed 14 years ago by anonymous

Attachment: ex_transport.log added

Changed 14 years ago by anonymous

Attachment: full_scan_ex_transports.log added

comment:2 Changed 14 years ago by anonymous

Logs attached (in case it had gone unnoticed)

Changed 14 years ago by danielk

possible fix

comment:3 Changed 14 years ago by danielk

Milestone: 0.19

Can you try the attached patch?

It looks like the "Leadtek LR6650" drops the FE_LOCK once you begin reading data from it. I won't use this patch on SVN, but if it works, I'll add a checkbox to ignore the FE_LOCK status during the scan.

comment:4 Changed 14 years ago by Stuart Morgan

The attached patch fixed the problem.

comment:5 Changed 14 years ago by danielk

Ok, I'll put in a checkbox for it next week.

comment:6 Changed 14 years ago by danielk

Resolution: fixed
Status: assignedclosed

(In [7654]) Closes #507, by giving option of a SLOW scan.

Basically the problem is that that the DVB drivers used by the "Leadtek LR6650" don't report an FE_LOCK in a reasonable time, even after they are delivering data to MythTV they are telling MythTV that they don't see any data out there... This is a serious driver bug. But my experience with DVB suggests that serious driver bugs are commonplace so I've added the option of allowing the channel scan to ignore the FE_LOCK status timeout altogether. This, of course, makes the scan take much longer, but it's probably preferable to not getting any channels from the scan.

Users that require this option may experience problems in MythTV as well, but MythTV tuning is a little more forgiving of broken drivers than the MythTV channel scan so YMMV.

Note: See TracTickets for help on using tickets.