Opened 14 years ago

Closed 14 years ago

#513 closed defect (fixed)

Teletext and arbitrary skip UI's incompatible with smart channel change in LiveTV mode

Reported by: danielk Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The teletext page switching requires you to type a teletext page number such as "888" and then press "T". But if you smart channel change enabled and have a channel 8 or 88 it will switch to that channel and clear the text entry before you can enter "T". "T" without a number is also used as a teletext/caption toggle.

The solution is to require "T" to be pressed to enter Teletext entry mode. Then another "T" can begin toggling, and a 3 digit number will select the page.

The arbitrary skip is also overloaded, but should be solved by using another key for arbitrary skip since double pressing the skip key would be unacceptable.

Change History (2)

comment:1 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk

comment:2 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [7689]) Fixes #513. Fixes some text input issues in LiveTV mode.

The problem is that with smart channel change enbled you can't enter a value for the Teletext page or the arbitrary skip that has a partial match with a channel on the current source listings source.

The solution for teltext/cc is to make users enter the Teletext key before entering a teletext page number, and then either press the Teletext key again or press select. If the user wants to perform a simple toggle they simply have to hit the key one extra time within a 500 ms time window.

For arbitrary seek I didn't want to add any new seek keys so I added a binding for *, which enters a safe arbitrary seek mode, which you then follow with the same seek buttons as before. If you don't enter this star character the old behavior is preserved. i.e. if doesn't alias a channel it skips, otherwise it changes the channel if in smart keys mode.

I also made it possible to select any teletext page, or use any of the common ATSC subchannel separators, so long as the entry begins with a number. So you can enter 5-1, if that is how you named your channel, without needing to change the audio select character or the subchannelsep character.

Note: See TracTickets for help on using tickets.