Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5137 closed defect (invalid)

mythfrontend seg fault on startup

Reported by: steve@… Owned by: Isaac Richards
Priority: major Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I rebuilt everything this morning from a updated svn tree: MythTV Version : 16916 MythTV Branch : trunk Library API : 0.22.20080320-2 Network Protocol : 40 Options compiled in:

linux release using_oss using_alsa using_arts using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_opengl using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live using_xvmc_pbuffer

when I start mythfrontend now I get a seg fault right away.

last few lines from startup (no verbose) 2008-04-03 09:02:48.793 Using the Qt painter 2008-04-03 09:02:48.795 JoystickMenuClient? Error: Joystick disabled - Failed to read /home/mythtv/.mythtv/joystickmenurc 2008-04-03 09:02:48.796 lirc init success using configuration file: /home/mythtv/.mythtv/lircrc 2008-04-03 09:02:48.982 Loading from: /usr/local/mythtv/share/mythtv/themes/default/base.xml 2008-04-03 09:02:49.150 Registering Internal as a media playback plugin. Segmentation fault

attaching full verbose output.

thanks

Attachments (1)

mythfrontend_gdb (2.4 KB) - added by andreaz@… 12 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by anonymous

seems the add attachment part thinks this file is spam and wont add it.

http://www.heistand.org/mythfrontend_output

comment:2 Changed 12 years ago by stuartm

Status: newinfoneeded_new

We need a backtrace as you should already know if you're running trunk right now.

We also need the QT version (update to [16917] and do mythfrontend --version).

comment:3 Changed 12 years ago by steve@…

there were 2 left over plugins (bookmarks and phone) that didnt get remade. they were trying to load old qt3 stuff and was killing things.

all better now thanks.

comment:4 Changed 12 years ago by stuartm

Resolution: invalid
Status: infoneeded_newclosed

Changed 12 years ago by andreaz@…

Attachment: mythfrontend_gdb added

comment:5 Changed 12 years ago by andreaz@…

I run into the exactly same error and have not idea howto fix it. Even a complete new checkout and new compile can't cure.

I wonder what you've done...?

comment:6 Changed 12 years ago by anonymous

there were old .so files in the plugins directory that tried to use old qt3. /usr/local/mythtv/libs/mythtv/plugins in my case. also libmythphone even though it was rebuilt was still using old qt3. I think the build process on that one is broken.

comment:7 Changed 12 years ago by andreaz@…

Thankyou alot!

I removed all *.so files in /usr/local/lib/mythtv/plugins/ and recompile from scratch. Works well!

Note: See TracTickets for help on using tickets.