Opened 12 years ago

Closed 12 years ago

#5166 closed defect (wontfix)

TV Preview constantly reloading, leads to blank screen when view changes to fullscreen

Reported by: tlawton@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Just updated to latest SVN (my last update, which worked fine, was before the QT4 changes). Running Core Duo T2400, Intel 945GM onboard graphics.

Using livetv, if the 'Preview' window is given time to load then it flashes (back to 'loading preview video') almost exactly once a second. This is accompanied by logging of a 'VideoRect/DisplayRect?' event. After this, changing to fullscreen leads to a blank (black) screen while the sound continues. Mythfrontend continues to respond to keypresses.

If the 'Preview' window is not given time to load (ie by pressing enter quickly), TV displays as normal.

Changing playback profiles doesn't appear to affect this (though I can't use XVMC anyway). Changing the OpenGL VSync setting doesn't affect it either.

Watching recordings works fine - but the 'live preview' has disappeared despite still being selected in setup. Changing it to 'thumbnail' displays a thumbnail as expected.

2 logs enclosed: 18:43:10 watching in preview, flashing 'Loading Preview Video' once a second

18:43:55 went to full screen - sound continues, black screen only

18:44:30 return to menu

18:44:50 watching recorded TV, working fine (but no preview video when choosing recording)

--

18:48:40 watching livetv by tapping 'enter' rapidly to avoid initial loading of preview video. Picture and sound display as expected.

Attachments (2)

MythTVPreviewBroken1.txt (46.4 KB) - added by tlawton@… 12 years ago.
First log as described in ticket
MythTVPreviewBroken2.txt (23.8 KB) - added by tlawton@… 12 years ago.
Second log as described in ticket (-v playback)

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by tlawton@…

Attachment: MythTVPreviewBroken1.txt added

First log as described in ticket

Changed 12 years ago by tlawton@…

Attachment: MythTVPreviewBroken2.txt added

Second log as described in ticket (-v playback)

comment:1 Changed 12 years ago by anonymous

The behaviour has changed now (running 19050 presently but it's been different for a while). The 'preview' still reloads as before, but on going to fullscreen (and getting a blankscreen initially) the screen updates and the picture is displayed as expected. However the underlying problem is presumably still there (as evidenced by reloading 'preview')

comment:2 Changed 12 years ago by stuartm

Resolution: wontfix
Status: newclosed

This will be fixed by the -vid branch merge and mythui port, until then I'm closing this as won't fix.

Note: See TracTickets for help on using tickets.