Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5218 closed defect (fixed)

Frontend segfaults when leaving mythnews

Reported by: mythdev@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When I go to MythNews? and exit it using the Escape key, my frontend segfaults:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb55f56d0 (LWP 26512)]
0x00000000 in ?? ()
(gdb) backtrace
#0  0x00000000 in ?? ()
#1  0xb6c6a5de in MythScreenType::keyPressEvent (this=0x846fc50,
    event=0xbfd5eca8) at mythscreentype.cpp:185
#2  0xb10b82ad in MythNews::keyPressEvent (this=0x846fc50, event=0xbfd5eca8)
    at mythnews.cpp:485
#3  0xb6c4a493 in MythMainWindow::eventFilter (this=0x83c22c0, e=0xbfd5eca8)
    at mythmainwindow.cpp:1330
#4  0xb5f1e4e2 in QApplicationPrivate::notify_helper ()
   from /usr/lib/qt4/libQtGui.so.4
#5  0xb5f21064 in QApplication::notify () from /usr/lib/qt4/libQtGui.so.4
#6  0xb5ab0b4b in QCoreApplication::notifyInternal ()
   from /usr/lib/qt4/libQtCore.so.4
#7  0xb5f71a5e in ?? () from /usr/lib/qt4/libQtGui.so.4
#8  0xb5f9d07b in ?? () from /usr/lib/qt4/libQtGui.so.4
#9  0xb5f9f031 in ?? () from /usr/lib/qt4/libQtGui.so.4
#10 0xb5f7bdef in QApplication::x11ProcessEvent ()
   from /usr/lib/qt4/libQtGui.so.4
#11 0xb5fa0204 in ?? () from /usr/lib/qt4/libQtGui.so.4
#12 0xb5aaff48 in QEventLoop::processEvents () from /usr/lib/qt4/libQtCore.so.4
#13 0xb5ab005a in QEventLoop::exec () from /usr/lib/qt4/libQtCore.so.4
#14 0xb5ab237b in QCoreApplication::exec () from /usr/lib/qt4/libQtCore.so.4
#15 0xb5f1dea7 in QApplication::exec () from /usr/lib/qt4/libQtGui.so.4
#16 0x0807bc86 in main (argc=1, argv=0xbfd5f874) at main.cpp:1541

As far as I can see in the sefault, it happens at MythSreenTypes?.cpp, line 185. There it says:

if (m_CurrentFocusWidget && m_CurrentFocusWidget->keyPressEvent(event))
        return true;

From this code it is not clear to me why there would be a segfault here, but maybe I am wrong.

My frontend version is: 0.22.20080416-1

Is there anything I can do to debug this problem further?

Change History (4)

comment:1 Changed 12 years ago by stuartm

Milestone: unknown0.22
Status: newinfoneeded_new
Version: unknownhead

Could you rebuild mythfrontend and the plugins after doing a make distclean.

P.S. I could be pedantic and point out that the version number you gave has nothing to do with the frontend version whatsoever but I won't ... (mythfrontend --version)

comment:2 Changed 12 years ago by mythdev@…

I already did a make distclean and rebuilded all the plugins. To make absolutely sure I first deleted alle the mythtv plugins and binaries.

Sorry about the version info. This is what mythfrontend --version says:

Please include all output in bug reports. MythTV Version : 17081 MythTV Branch : trunk Library API : 0.22.20080416-1 Network Protocol : 40 QT Version : 4.3.4 Options compiled in:

linux debug using_alsa using_backend using_frontend using_lirc using_v4l using_x11 using_xv using_xvmc using_xvmc_vld using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads

comment:3 Changed 12 years ago by stuartm

Resolution: fixed
Status: infoneeded_newclosed

(In [17085]) Fixes #5218

I've no idea how I let this bug slip through or why I was unable to reproduce, but segfaults leaving certain plugin screens should now be fixed.

comment:4 Changed 12 years ago by stuartm

(In [17092]) Remove the unpopular menus from the main mythgallery screen and put them in mythui popups instead, this gives more room for thumbnails and matches up with the behaviour everywhere else in MythTV.

Includes a couple of warning fixes; the mythgallery fix for #5218 which I had left out of [17085] because this commit was pending; and a simplification of ThumbGenEvent?.

Thanks should go to Paul for [17088], [17089] and [17090] - he just didn't know that I'd already fixed these problems in my tree.

Refs #5218

Note: See TracTickets for help on using tickets.