Opened 12 years ago

Closed 12 years ago

#5256 closed patch (fixed)

osd char scaling sometimes incorrect

Reported by: Mark Spieth Owned by: Stuart Auchterlonie
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

the osd char spacing is sometimes incorrect. notably SD dvb res 720x576 16:9 images being displayed on 16:9 displays.

scaling does not occur correctly for most ttfonts. FT_Set_Char_Size does not work on fonts which dont have narrow and wide versions embedded. Thus FT_Set_Transform is needed to do it mathematically.

This has been tested with Retro-OSD and Gray-OSD and results are good. I believe this is the correct way to do horizontal scaling.

Attachments (1)

mythtv_osdspacing.1.patch (643 bytes) - added by Mark Spieth 12 years ago.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by Mark Spieth

Attachment: mythtv_osdspacing.1.patch added

comment:1 Changed 12 years ago by Jules Bean <jules@…>

I can confirm that this fixes some OSD font spacing glitches that I was seeing on (I think) 16:9 images being displayed on a 4:3 display.

comment:2 Changed 12 years ago by Simon Kenyon <simon@…>

ust tried this. whoops for joy. this works! for the first time in so very long i can read the OSD without trouble.

i tried the following OSDs to make sure. in most case if just went through 4:3 and 16:9 and tried at least two fill modes. for some i checked all. but it really seems to be fixed.

Retro, Titivillus, blootube-OSD, Blue, Default, Gray, Isthmus, Iulius, MePo?-wide, Metallurgy, projectgrayhem-OSD.

so it works for "official" as well as "user supplied" OSD themes.

for Retro i tried all fill modes. for Isthmus i tried all aspect ratios. for projectgraphem-OSD i tried all combinations of both.

this was on a 16:10 display. will try later on a real 16:9 display. i don't have a 4:3 to test it with

could this be applied to trunk?

thank you so much

comment:3 Changed 12 years ago by Stuart Auchterlonie

Milestone: unknown0.22
Owner: changed from Isaac Richards to Stuart Auchterlonie
Status: newassigned
Version: unknownhead

Having suffered from this for a while I thought i'd test it out. Seeing that it works just fine it's going in.

comment:4 Changed 12 years ago by Stuart Auchterlonie

(In [17183]) Refs #5256. Applies a patch from Mark Spieth to fix the bad horizontal scaling of the OSD under certain resolution & dpi combos

comment:5 Changed 12 years ago by Stuart Auchterlonie

Resolution: fixed
Status: assignedclosed

(In [17184]) Closes #5256. Backports a patch from Mark Spieth to fix the bad horizontal scaling of the OSD under certain resolution & dpi combos

Note: See TracTickets for help on using tickets.