Opened 12 years ago

Closed 11 years ago

#5258 closed defect (fixed)

DVD playback blank on certain DVD

Reported by: antony.gelberg@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.21
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This could become quite complicated, but I will give the information I have, and please ask if you have any other questions about my setup. I'm using 0.21-0.13 from the Debian Multimedia packages, Debian Lenny (testing) with a 2.6.18 kernel and nvidia binary graphics driver.

Most of my DVDs play fine (aside from the odd graphical glitch) under the Myth internal player, except for Long Way Down. It is a 2-disc set, and the problem occurs on both disks, so I rule out bad media. It plays fine on the same machine under xine, therefore I assume the problem is in the Myth player.

The DVD menu loads fine, however upon selecting a chapter, the screen goes blank, and the DVD doesn't play. There is no audio or video, however the DVD drive light does flicker as if it's playing, and the VFD indicates the usual DVD metadata and progress.

To be specific, the screen is not entirely blank, but becomes a very dark, faded version of the DVD menu.

One strange thing is that even though nothing is displayed if I skip ahead or back with the left and right arrows, I am greeted by a still of the DVD at the skip point. The menu button appears not to function.

I should also point out that this behaviour has gotten worse in recent months - Chapters 1 and 2 of the DVD used to play successfully (chapter 3 didn't). Unfortunately I don't keep upgrade records, so I am unable to provide dates or versions.

I have attached a log.

Attachments (1)

dvdhang.log (4.2 KB) - added by antony.gelberg@… 12 years ago.
Log from DVD playback failure

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by antony.gelberg@…

Attachment: dvdhang.log added

Log from DVD playback failure

comment:1 Changed 12 years ago by skamithi

Status: newinfoneeded_new

before reporting any dvd menu problems, upgrade the latest 0.21-fixes or trunk, then *disable* any adaptive interlacer (yadif, greedymotion). use linear blend or one-field deinterlacer.

if the issue is still reproducible, open a ticket.

There is an ongoing bug where dvd still frames may not show on a dvd with adaptive deinterlacers.

I am doing my best to commit dvd menu fixes in 0.21-fixes as well as in trunk.

comment:2 Changed 12 years ago by antony.gelberg@…

I had some trouble finding the setting, as I last looked at the renderer a while ago, when it had been set to Bob. When I found the Playback Profiles menu, it had been using CPU+ (which uses Bob).

I set it to Slim which uses linearblend or onefield by default, but there was no difference in the behaviour. I also tried Normal, just for interest. Looking at http://www.mythtv.org/wiki/index.php/Playback_profiles#Normal_default_settings, I would assume it uses greedyhdoubleprocessdeint for DVD playback. With this setting, when I selected the chapter from the menu, the system behaved as described originally, however the menu stayed bright, it wasn't faded as originally reported.

I will try next with trunk, if I can get it built and installed without trampling over my binary package installation.

comment:3 Changed 12 years ago by antony.gelberg@…

I should have been clearer, I did the tests with the 0.21-0.13 Debian package, and was going to try both 0.21-fixes and then trunk next. I've been advised via email not to use trunk at the moment as it requires lots of system changes and isn't in a good state. I /will/, however, try svn 0.21-fixes next, as requested.

comment:4 in reply to:  1 Changed 12 years ago by antony.gelberg@…

Works for me in 0.21-fixes. Thank you and please close this report.

comment:5 Changed 11 years ago by stuartm

Resolution: fixed
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.