Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5266 closed defect (invalid)

SD and HD showings of the same program are recorded

Reported by: nswint@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

I thought that this was just a bug with Dateline NBC. But the same SD and HD showing are recording as if they were seperate programs.

Here is another instance (Both are set to record)

74 SCIFI Stargate Atlantis Mon, May 5, 05:00 PM to 06:00 PM (60 mins) A team leads an expedition to a distant galaxy. (TV-PG, CC, Stereo, Rerun) Category: Science fiction Type: series (EP00666541) Original Airdate: 2004-07-16 Program ID: SH006665410000

874 SCIFIHD Stargate Atlantis Mon, May 5, 05:00 PM to 06:00 PM (60 mins) A team leads an expedition to a distant galaxy. (TV-PG, CC, Stereo, Rerun) Category: Science fiction Type: series (EP00666541) Original Airdate: 2004-07-16 Program ID: SH006665410000 Cast: Amanda Tapping, David Hewlett, Jason Momoa, Joe Flanigan, Rachel Luttrell

Stargate Atlanis is setup to be recorded as such:

Record at any time on any channel. Duplicate Check Method: Subtitle and Description Preferred Input: Any

Change History (9)

comment:1 Changed 12 years ago by Scott Atkins <Scott.Atkins@…>

I believe this is a result of the episode being generic. As a result there is no way to tell that it is the same show. I mean who's to say that the episode on UPN at the same time as the SciFi? channel are the same if they are both generic as well?

I don't think there's a way to fix this issue.

comment:2 Changed 12 years ago by anonymous

I added this to the Wish List a while back but I'm not sure how often people check it.

http://www.mythtv.org/wiki/index.php/Feature_Wishlist_%28Backend_Addons%29

Generic episodes that air at the same time should only record once. I record The Simpsons which doesn't always have specific show information. I want to record even the generic episodes, but when they are generic, I always get 2 copies. One from my SD channel (44) and one on my HD channel (44.1). The scheduler should be smart enough to know that if the show is generic and on at the same time as another generic episode, then it's likely the same episode even though the xmltv id's aren't exactly the same.

comment:3 Changed 12 years ago by Scott Atkins <Scott.Atkins@…>

Wait, since mythtv can't figure out if the two episodes are the same, you want it to ignore one? That seems like the wrong behavior to me. It is much safer to record both, and have the user say which one to keep (or in the case of one recorder, let the user decide which one to keep from the upcoming recordings).

comment:4 Changed 12 years ago by anonymous

I'm saying MythTV should be smart enough to know they are the same program. There should be some way to associate channels as always airing the some content but in a different format (HD vs SD) so it knows to only record 1.

comment:5 Changed 12 years ago by Scott Atkins <Scott.Atkins@…>

Ah, but you can't assume that the HD channel always shows the same thing as the SD channel, PBS is a great example of this.

Yes a parameter could be added to the db to link channels programming information, but unless you're the one broadcasting, you cannot make that guarantee. By doing what it is doing right now, corner cases like this are avoided and no one screams about missing a recording.

comment:6 in reply to:  4 Changed 12 years ago by nswint@…

Replying to anonymous:

I'm saying MythTV should be smart enough to know they are the same program. There should be some way to associate channels as always airing the some content but in a different format (HD vs SD) so it knows to only record 1.

I would think that logic would apply since it has the same program id, but showing on a different channel and should have the hd flag. This type of behavior is new to MythTV 0.21. Prior to that only one sd or hd show on multiple channels would record.

comment:7 in reply to:  5 ; Changed 12 years ago by gigem

Resolution: invalid
Status: newclosed

Replying to Scott Atkins <Scott.Atkins@gmail.com>:

Yes a parameter could be added to the db to link channels programming information, but unless you're the one broadcasting, you cannot make that guarantee. By doing what it is doing right now, corner cases like this are avoided and no one screams about missing a recording.

The way to do that is to use the same callsign for both channels. In this case, make them both be 'SCIFI' and the SD and the HD programs will be considered the same, even though they are marked as generic.

comment:8 in reply to:  7 Changed 12 years ago by Scott Atkins <Scott.Atkins@…>

Replying to gigem:

Replying to Scott Atkins <Scott.Atkins@gmail.com>:

Yes a parameter could be added to the db to link channels programming information, but unless you're the one broadcasting, you cannot make that guarantee. By doing what it is doing right now, corner cases like this are avoided and no one screams about missing a recording.

The way to do that is to use the same callsign for both channels. In this case, make them both be 'SCIFI' and the SD and the HD programs will be considered the same, even though they are marked as generic.

Actually that doesn't work. For example, in my area we have OPB (Oregon Public Broadcasting) and OPBHD. They have the same basic programming (for example the show Nova) but different schedules. The HD channel will replay Nova a number of extra times the SD doesn't get.

comment:9 Changed 12 years ago by stuartm

Ticket locked: set

It's been established that the behaviour you are seeing is intentional and not a bug, so this ticket qualifies as a "Feature request without a patch". If you can come up with a solution which is acceptable to everyone and are able to produce a patch, then open a new ticket, otherwise please continue discussing this on the mailing lists and not in trac.

Note: See TracTickets for help on using tickets.