Opened 12 years ago

Closed 11 years ago

#5273 closed patch (duplicate)

mythweb - weather module - animated maps fix for release-0-21-fixes branch

Reported by: Paul Sands <usg990a@…> Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: mythweb Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The current php template does not properly load the radar images if mythweb it not to root of the host server (or a vhost). So if the url to access is http://192.168.0.100/mythweb/weather then the original php file looks for http://192.168.0.100/data/cache/whatever-0 instead of looking for http://192.168.0.100/mythweb/data/cache/whatever-0.

Attached is a diff of 0-21-fixes weather.am.php at SVN 16203. It works fine for me using a non-root mythweb but may need further testing / verification before being applied (i.e. not sure how it would effect vhost configuration).

Attachments (1)

weather.am.php.diff (1.1 KB) - added by Paul Sands <usg990a@…> 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by Paul Sands <usg990a@…>

Attachment: weather.am.php.diff added

comment:1 in reply to:  description Changed 12 years ago by Paul Sands <usg990a@…>

Replying to Paul Sands <usg990a@cebridge.net>:

The current php template does not properly load the radar images if mythweb it not to root of the host server (or a vhost).

Sorry, apparently I cannot type this evening. That should say:

The current php template does not properly load the radar images if mythweb is not the root of the host server (or a vhost).

comment:2 Changed 12 years ago by anonymous

Different (and incomplete) fix but this is a dupe of Ticket 5171

<http://svn.mythtv.org/trac/ticket/5171>

comment:3 Changed 12 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: newaccepted

comment:4 Changed 11 years ago by Rob Smith

Resolution: duplicate
Status: acceptedclosed

Dupe of #5171

Note: See TracTickets for help on using tickets.