Opened 12 years ago

Closed 11 years ago

#5284 closed patch (fixed)

Update minimum required MySQL DBMS version

Reported by: sphery <mtdean@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The attached patch updates the minimum required MySQL DBMS version to 5.0.15. [17160] removed some compatibility code required for MySQL versions 5.0.2 and below, so simply checking the major version is no longer sufficient. Since 5.0.15 was the first stable release of MySQL ( http://dev.mysql.com/doc/refman/5.0/en/roadmap.html : "The current production release series is MySQL 5.0, which was declared stable for production use as of MySQL 5.0.15, released in October 2005." ), it makes sense to require that version or greater. See, also, discussion in the thread at http://www.gossamer-threads.com/lists/mythtv/dev/332004#332004 .

The patch uses 3 defines--one each for major, minor, and point versions--as it was the easiest way to make the values work for both DBUtil::CompareDBMSVersion() and the error message.

The patch was created and tested on post-Qt4 trunk. Use the undocumented setting, 'DBMSVersionOverride', to test different MySQL versions (and feel free to put extra garbage in as it's possible in the wild--it works, though).

Attachments (3)

mythtv-5284-minimum_MySQL_version.patch (1.9 KB) - added by sphery <mtdean@…> 12 years ago.
mythtv-5284-minimum_MySQL_version-20080728.patch (1.9 KB) - added by sphery <mtdean@…> 11 years ago.
Updated patch for recent changes to trunk.
mythtv-5284-minimum_MySQL_version-20080729.patch (1.0 KB) - added by sphery <mtdean@…> 11 years ago.
Updated patch to work with schemawizard

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by sphery <mtdean@…>

Changed 11 years ago by sphery <mtdean@…>

Updated patch for recent changes to trunk.

Changed 11 years ago by sphery <mtdean@…>

Updated patch to work with schemawizard

comment:1 Changed 11 years ago by sphery <mtdean@…>

Added mythtv-5284-minimum_MySQL_version-20080729.patch to update the patch for use with post-schemawizard trunk. The patch simply changes the minimum DBMS version. It does not re-enable checking the DBMS version when not upgrading the DB. See also my comment in "Re: [mythtv-commits] mythtv commit: r17875 by nigel" thread on -dev for more info.

comment:2 Changed 11 years ago by Nigel

Resolution: fixed
Status: newclosed

(In [17975]) Update minimum required MySQL version to the first stable version, 5.0.15. Closes #5284 (with a slightly simpler version than Michael's patch).

Note: See TracTickets for help on using tickets.