Opened 12 years ago

Closed 12 years ago

#5307 closed defect (fixed)

Mythfrontend dies at SIGSEGV when starting LiveTV

Reported by: hatuomin@… Owned by: Isaac Richards
Priority: major Milestone: 0.21.1
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by paulh)

After updating to mythtv-frontend-0.21-187.fc8 frontend get SIGSEGV then starting LiveTV or loading video list or etc. This totally prevent usage of mythtv Linux 2.6.24.5-85.fc8 #1 SMP Sat Apr 19 12:39:34 EDT 2008 i686 athlon i386 GNU/Linux AMD Athlon(tm) 64 Processor 3200+

[root@localhost mythtv]# mythbackend --version
Please include all output in bug reports.
MythTV Version   : 17180M
MythTV Branch    : branches/release-0-21-fixes
Library API      : 0.21.20080304-1
Network Protocol : 40
Options compiled in:
 linux release using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_glx_proc_addr_arb using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live
[root@localhost mythtv]# mythfronend --version
-bash: mythfronend: command not found
[root@localhost mythtv]# mythf --version
mythfilldatabase  mythfrontend
[root@localhost mythtv]# mythfrontend --version
Please include all output in bug reports.
MythTV Version   : 17180M
MythTV Branch    : branches/release-0-21-fixes
Library API      : 0.21.20080304-1
Network Protocol : 40
Options compiled in:
 linux release using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_glx_proc_addr_arb using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

gdb bt trace when starting to see list of videos
#0  0x051d3eff in QGArray (this=0xbfbdc7f8, a=@0x0) at tools/qgarray.cpp:164
#1  0x04ec6bf4 in QTranslator::findMessage (this=0x91d86c0, context=0x52b37a0 "QObject", sourceText=0x25c9ab4 "Unknown Prefix", comment=0x53580f7 "")
    at ../include/qmemarray.h:63
#2  0x04e741e7 in QApplication::translate (this=0xbfbdd458, context=0x52b37a0 "QObject", sourceText=0x25c9ab4 "Unknown Prefix", comment=0x0,
    encoding=QApplication::DefaultCodec) at kernel/qapplication.cpp:3059
#3  0x05264292 in QObject::tr (s=0x549193c "�", c=0x0) at .moc/release-shared-mt/moc_qobject.cpp:35
#4  0x0259a787 in VideoListImp::buildDbList () from /usr/lib/mythtv/plugins/libmythvideo.so
#5  0x0259b2dc in VideoListImp::fillMetadata () from /usr/lib/mythtv/plugins/libmythvideo.so
#6  0x0259b38c in VideoListImp::refreshList () from /usr/lib/mythtv/plugins/libmythvideo.so
#7  0x0259b408 in VideoListImp::buildVideoList () from /usr/lib/mythtv/plugins/libmythvideo.so
#8  0x0259b6e0 in VideoList::buildVideoList () from /usr/lib/mythtv/plugins/libmythvideo.so
#9  0x02590ae0 in VideoDialog::fetchVideos () from /usr/lib/mythtv/plugins/libmythvideo.so
#10 0x0258830d in VideoGallery::fetchVideos () from /usr/lib/mythtv/plugins/libmythvideo.so
#11 0x0258a37f in VideoGallery::VideoGallery () from /usr/lib/mythtv/plugins/libmythvideo.so
#12 0x0253a078 in ?? () from /usr/lib/mythtv/plugins/libmythvideo.so
#13 0x0253a76f in ?? () from /usr/lib/mythtv/plugins/libmythvideo.so
#14 0x005ab1d5 in MythMainWindow::ExitToMainMenu () from /usr/lib/libmythui-0.21.so.0
#15 0x005ac69e in MythMainWindow::customEvent () from /usr/lib/libmythui-0.21.so.0
#16 0x04ed718e in QObject::event (this=0x914b338, e=0x91253a8) at kernel/qobject.cpp:758
#17 0x04f13fbc in QWidget::event (this=0x914b338, e=0x91253a8) at kernel/qwidget.cpp:4681
#18 0x04e6e4eb in QApplication::internalNotify (this=0xbfbdd458, receiver=0x914b338, e=0x91253a8) at kernel/qapplication.cpp:2638
#19 0x04e6fac7 in QApplication::notify (this=0xbfbdd458, receiver=0x914b338, e=0x91253a8) at kernel/qapplication.cpp:2526
#20 0x04e6f579 in QApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qapplication.h:523
#21 0x04e6f716 in QApplication::sendPostedEvents () at kernel/qapplication.cpp:3213
#22 0x04e159da in QEventLoop::processEvents (this=0x9065328, flags=4) at kernel/qeventloop_x11.cpp:205
#23 0x04e87dc0 in QEventLoop::enterLoop (this=0x9065328) at kernel/qeventloop.cpp:201
#24 0x04e87c76 in QEventLoop::exec (this=0x9065328) at kernel/qeventloop.cpp:148
#25 0x04e6e12f in QApplication::exec (this=0xbfbdd458) at kernel/qapplication.cpp:2761
#26 0x0806d2f8 in QWidget::setUpdatesEnabled () at kernel/qwidget.cpp:3907
#27 0x00abc390 in __libc_start_main (main=0x806b3b0 <QWidget::setUpdatesEnabled(bool)+43532>, argc=1, ubp_av=0xbfbdd844, init=0x81736c0, fini=0x81736b0,
    rtld_fini=0x339940 <_dl_fini>, stack_end=0xbfbdd83c) at libc-start.c:220
#28 0x080609e1 in QWidget::setUpdatesEnabled () at kernel/qwidget.cpp:3907

Change History (2)

comment:1 Changed 12 years ago by paulh

Description: modified (diff)

comment:2 Changed 12 years ago by paulh

Resolution: fixed
Status: newclosed

If you are using the Finnish translation then this bug has already been fixed. It was caused by a corrupt translation file.

Note: See TracTickets for help on using tickets.