Opened 14 years ago

Closed 14 years ago

#532 closed defect (worksforme)

NFS: can skip past end of pseudo-live recording

Reported by: gdragon@… Owned by: Isaac Richards
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Using latest svn 7602, It is possible to skip past the end of a pseudo-live recording (ie watching a recording that is still recording). Using the arrow keys to skip forward, skip to a point that would be past the end of the recording. It appears to work at first, as the osd indicates that you are at a point just prior (3 seconds) to the end of time. The playback then stops, and deposits you back to the menu. This isn't too big of a deal, but it is an annoyance.

From the log it appears that something is calling the VideoOutputXv? destructor, but the log does not indicate why.

Frontend log with -v all is attached.

Attachments (3)

myth_fe_skipahead.log (3.4 KB) - added by gdragon@… 14 years ago.
frontend log with -v all
myth_fe_skipahead_2.log (2.8 KB) - added by gdragon@… 14 years ago.
better log IMHO, with network & sound removed
myth_5_fe.log (21.2 KB) - added by gdragon@… 14 years ago.

Download all attachments as: .zip

Change History (10)

Changed 14 years ago by gdragon@…

Attachment: myth_fe_skipahead.log added

frontend log with -v all

Changed 14 years ago by gdragon@…

Attachment: myth_fe_skipahead_2.log added

better log IMHO, with network & sound removed

comment:1 Changed 14 years ago by danielk

I can't reproduce this.

Can you produce complete logs (from startup to shutdown) of the frontend and backend with "-v playback" and "-v record,channel" respectively. And set DEBUG_ACTIONS to 1 in tv_play.cpp? And, annotate the frontend log with what keys you hit at any point.

Also what kind of capture card are you using?

Are you streaming over the network?

comment:2 Changed 14 years ago by gdragon@…

Resolution: worksforme
Status: newclosed

Hmm.. apparently I can't either anymore. I can not reproduce this right now with either tuner.

I could do it very easily this earlier tonight & this weekend. Tonight i was using a remote frontend (box 3)over the network, and playing a recording on a pvr-250. On Sunday I was also watching something on off of the pvr-250, but I was on the master backend/frontend (box 1), tho the pvr-250 was installed in the slave backend (box 2), so the network would also been a factor here too.

I have seen this numerous times before, and I don't think it was exclusively on the PVR card. I also have 3 pchd-3000's.

I will keep an eye out for this problem again, and re-open this ticket & get the logs requested above, if I can get the problem to reoccur.

comment:3 Changed 14 years ago by gdragon@…

Resolution: worksforme
Status: closedreopened

I got it to reoccur today. So far it seems to be limited to the recordings that I do with the PVR-x50 (analog tuner). I have got this to occur on the stand-alone frontend, (log attached.) I also got it to occur on the master backend, which incidently was not the backend recording it.

The frontend log is attached, beginning to end, I think as you asked. The backend log will be harder to obtain, as it's been running for weeks, and I'll have to parse thought it. (unless you want a 557M log ;() Let me know.

Changed 14 years ago by gdragon@…

Attachment: myth_5_fe.log added

comment:4 Changed 14 years ago by danielk

Milestone: 0.20
Summary: can skip past end of pseudo-live recordingNFS: can skip past end of pseudo-live recording

Moving to 0.20. This is very difficult to reproduce and may just be an NFS configuration issue.

comment:5 Changed 14 years ago by cpinkham

I believe this issue is related to NFS file attribute caching. Can you try remounting your NFS directory with the "-o actimeo=0" option and see if you can reproduce the problem still? I think the backend is telling the frontend that the file is of X size, but the frontend can only see X-Y since it has cached the file attributes for the file. The actimeo=0 option will tell NFS to not cache the attributes so the frontend will always get the latest filesize, data, etc. when it uses a nfs-mounted file.

comment:6 Changed 14 years ago by gdragon

I believe that it was probably the issue. Unfornately I don't have an easy way to test it right now, since I currently don't have a source for that tuner and PC.

Has this info made it into the documentation? I'd recommend closing it. If i can ever reproduce it, it can be opened again.

comment:7 Changed 14 years ago by cpinkham

Resolution: worksforme
Status: reopenedclosed

Closing ticket, I believe Robert said he added something to the HOWTO and I know something is in the Wiki about the actimeo=0 option.

Note: See TracTickets for help on using tickets.