Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#534 closed enhancement (invalid)

EITScanner scans same channel on 2 cards at the same time

Reported by: t0mm0p@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

i have 2 dvb-t cards. from the log, it seems EITScanner is working on both cards at the same time scanning the exact same channels and entering the same info into the db twice. this uses lots of cpu and seems like a waste.

2005-10-27 02:09:44.973 Using runtime prefix = /usr/local
2005-10-27 02:09:44.986 New DB connection, total: 1
Starting up as the master server.
2005-10-27 02:09:44.996 mythbackend: MythBackend started as master server
2005-10-27 02:09:44.998 New DB connection, total: 2
2005-10-27 02:09:44.999 New DB connection, total: 3
2005-10-27 02:09:45.053 DVB#0 Using DVB card 0, with frontend 'Hauppauge Nova-T DVB-T'.
2005-10-27 02:09:45.062 TVRec(3) Error: Start channel '' invalid, setting to '1' instead.
2005-10-27 02:09:45.129 DVB#1 Using DVB card 1, with frontend 'Hauppauge Nova-T DVB-T'.
2005-10-27 02:09:45.138 New DB scheduler connection
2005-10-27 02:09:45.200 mythbackend version: 0.19.20051023-1 www.mythtv.org
2005-10-27 02:09:45.201 Enabled verbose msgs : important general
2005-10-27 02:09:45.202 AutoExpire: Found 2 recorders w/max rate of 277 MiB/min
2005-10-27 02:09:45.202 AutoExpire: space: 3.2 GB w/freq: 5 min
2005-10-27 02:09:47.200 Reschedule requested for id -1.
2005-10-27 02:09:47.297 Scheduled 31 items in 0.1 = 0.07 match + 0.03 place
2005-10-27 02:09:47.299 scheduler: Scheduled items
2005-10-27 02:09:47.302 Recording starts soon, AUTO-Startup assumed
2005-10-27 02:09:55.202 mythbackend: Running housekeeping thread
2005-10-27 02:10:45.511 DVB#1 Using DVB card 1, with frontend 'Hauppauge Nova-T DVB-T'.
2005-10-27 02:10:45.568 EITScanner(): Now looking for EIT data on channel 30
2005-10-27 02:10:45.680 DVB#0 Using DVB card 0, with frontend 'Hauppauge Nova-T DVB-T'.
2005-10-27 02:10:45.785 EITScanner(): Now looking for EIT data on channel 30
2005-10-27 02:10:46.558 DVB#0 DVB SI Table Parser Started
2005-10-27 02:10:46.604 DVB#1 DVB SI Table Parser Started
2005-10-27 02:11:23.681 New DB connection, total: 4
2005-10-27 02:11:23.682 New DB connection, total: 5
2005-10-27 02:11:23.686 New DB connection, total: 6
2005-10-27 02:15:45.632 EITScanner(): Added 454 EIT Events
2005-10-27 02:15:45.632 Reschedule requested for id -1.
2005-10-27 02:15:45.729 Scheduled 30 items in 0.1 = 0.07 match + 0.03 place
2005-10-27 02:15:45.825 EITScanner(): Added 454 EIT Events
2005-10-27 02:15:45.825 Reschedule requested for id -1.
2005-10-27 02:15:45.889 DVB#1 Using DVB card 1, with frontend 'Hauppauge Nova-T DVB-T'.
2005-10-27 02:15:46.036 Scheduled 30 items in 0.2 = 0.13 match + 0.08 place
2005-10-27 02:15:46.042 EITScanner(): Now looking for EIT data on channel 15
2005-10-27 02:15:46.113 DVB#0 Using DVB card 0, with frontend 'Hauppauge Nova-T DVB-T'.
2005-10-27 02:15:46.304 EITScanner(): Now looking for EIT data on channel 15
2005-10-27 02:15:46.798 DVB#1 DVB SI Table Parser Started
2005-10-27 02:15:46.979 DVB#0 DVB SI Table Parser Started

Change History (2)

comment:1 Changed 14 years ago by danielk

Milestone: unknown
Resolution: invalid
Status: newclosed
Type: defectenhancement

Having some kind a smart channel scan that coordinated with other recorders would be nice. But since this is a feature request, and not a bug, I'm going to have to mark this as ticket as invalid. Reopen with patch...

comment:2 Changed 14 years ago by Stuart Auchterlonie

After the changes in [7659] you can now stop the eitscanner from scanning on both cards.

Setup one of the cards to have a videosource of onairguide but turn off the checkbox that allows EIT updates.

The other card should have another videosource of onairguide but turn on the checkbox that allows EIT updates.

Yes, this means you define 2 different videosources, and it's not entirely obvious or intuitive, but it will at least achieve what you want. For now it's the only way to do it.

Note: See TracTickets for help on using tickets.