Opened 13 years ago

Closed 12 years ago

#5340 closed defect (duplicate)

Icon downloader selection box disables items

Reported by: mythtv@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords: icon icons
Cc: Ticket locked: no

Description

When using the icon downloader to manually search/select icons for a channel, I've encountered an odd issue. Sometimes, I'll get several possible matches, but will only be allowed to pick from the bottom few. When moving the focus from the channel name at the top to the selection box, I can walk through all the options the first time. However, once I try to select a "disabled" option, the focus jumps immediately to the highest most "enabled" option and I am no longer allowed to scroll back up to any of the "disabled" options. (I say "disabled" because there's no indication that the selection is actuall disabled. It's not greyed out or anything)

This issue seems to coincide with any time there's a '+' in any of the returned channel names.

Currently, I can reproduce this issue by entering the following strings into the search box:

CNN HD Disney Channel HD National Geographic National Geographic HD WGN

In all cases, trying to select the "correct" option leads to this behavior.

Change History (3)

comment:1 Changed 13 years ago by mythtv@…

That's what I get for not clicking "preview". The affected strings I've run into are:

CNN HD
Disney Channel HD
National Geographic
National Geographic HD
WGN

comment:2 Changed 13 years ago by Matthew Wire <devel@…>

This looks like a duplicate of #4427

comment:3 Changed 12 years ago by stuartm

Resolution: duplicate
Status: newclosed

Duplicate of #4427. It's a QT bug, fixed by the QT upgrade in trunk, but no easy fix is possible in -fixes.

Note: See TracTickets for help on using tickets.