Opened 12 years ago

Closed 11 years ago

Last modified 9 years ago

#5351 closed defect (worksforme)

Internal player can't downmix 5.1 AAC properly

Reported by: james@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords: audio aac downmix stereo 5.1
Cc: Ticket locked: no

Description

With the internal player, all my .mp4 files (which contain h.264 video, with 5.1 AAC audio), playback is extremely slow and stuttery, with high pitch artefacts.

Notes:

  • Doesn't occur with files with only 2 channel audio, only 5.1
  • If audio setup is switched to 5.1 (in the audio options), problem goes away

Probably something to do with 5.1 AAC downmixing to stereo.

Change History (3)

comment:1 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

Can you please try with current trunk? A lot of changes have happened in h.264 support recently. Please backup your database first.

comment:2 Changed 11 years ago by stuartm

Milestone: unknown0.22
Resolution: worksforme
Status: infoneeded_newclosed

I can't reproduce this with trunk or 0.21. There has been no followup from the original reporter or any subsequent reports from other users so I'm closing this unless anyone can confirm that it is still an issue.

comment:3 Changed 9 years ago by riscycdj@…

I have the same problem as specified in the original ticket. I couldn't work out why some Blu Ray rips were not playing back correctly and others were. The only difference is 5.1 downmixing. I am using 0.23+fixes on the Mythbuntu distribution. I'm not sure what extra information is required to help troubleshoot this issue.

Here is an extract from mythfrontend.log:

2010-08-14 19:02:58.569 TV: Attempting to change from None to WatchingVideo
2010-08-14 19:02:59.937 AFD: Opened codec 0x7bd73e0, id(H264) type(Video)
2010-08-14 19:02:59.937 AFD: codec AAC has 6 channels
2010-08-14 19:02:59.937 AFD: Opened codec 0x8539260, id(AAC) type(Audio)
2010-08-14 19:02:59.963 Opening audio device 'default'. ch 2(2) sr 48000 (reenc 0)
2010-08-14 19:02:59.963 Opening ALSA audio device 'default'.
2010-08-14 19:03:00.100 VDPAU: Created 2 output surfaces.
2010-08-14 19:03:00.100 VDPAU: Created VDPAU render device 1920x1080
2010-08-14 19:03:00.203 NVP(11): Forcing decode extra audio option on (Video method requires it).
2010-08-14 19:03:00.203 OSD Theme Dimensions W: 640 H: 480
2010-08-14 19:03:00.277 TV: Changing from None to WatchingVideo
2010-08-14 19:03:00.284 Realtime priority would require SUID as root.
2010-08-14 19:03:00.308 ScreenSaverX11Private: DPMS Deactivated 1
2010-08-14 19:03:00.328 OpenGLVideoSync()
2010-08-14 19:03:00.337 No DTS Seeking Hack!
2010-08-14 19:03:00.426 WriteAudio: buffer underrun
2010-08-14 19:03:00.443 Video sync method can't support double framerate (refresh rate too low for bob deint)
2010-08-14 19:03:00.469 Video timing method: SGI OpenGL
2010-08-14 19:03:00.562 VDPAU: Added 2 output surfaces (total 4, max 4)
2010-08-14 19:03:05.480 ScreenSaverX11Private: DPMS Reactivated 1
2010-08-14 19:03:08.744 Marking recording as unwatched
2010-08-14 19:03:08.794 TV: Attempting to change from WatchingVideo to None
2010-08-14 19:03:08.794 TV: Changing from WatchingVideo to None

Note: See TracTickets for help on using tickets.