Opened 11 years ago

Closed 10 years ago

#5359 closed defect (worksforme)

apostrophes in Program sub-title break previous recording detection

Reported by: jackie.m@… Owned by:
Priority: minor Milestone: 0.22
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If a program has an apostrophe (single quote in programming terms) in it's subtitle ex: "Batman - It's Never Too Late" the program will not be detected as previously recorded, and will therefore record again. This appears to have been introduced in a upgrade from 0.20.2 to 0.21, but I am not completely sure of this.

The environment: Fedora 8 mythtv-0.21-187.fc8 from atrpms

I see nothing in the logs other than normal recording of the program (start, stop, commercial flag, etc.). This does not effect the program title (Ex: Monty Python's Flying Circus, Foster's Home for Imaginary Friends)

Change History (6)

comment:1 Changed 11 years ago by stuartm

Milestone: 0.21.1
Owner: changed from Isaac Richards to stuartm
Status: newassigned

comment:2 Changed 11 years ago by stuartm

Owner: stuartm deleted
Status: assignednew

comment:3 Changed 10 years ago by stuartm

Milestone: 0.21.10.22
Status: newinfoneeded_new

Can anyone reproduce this with trunk?

comment:4 Changed 10 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Tested this on trunk @ 20931 and could not reproduce the behaviour.

For the test I:

i) created a channel rule (subtitle and description) for a title

ii) marked an episode as Never Record to falsify a previous recording

iii) edited the showing's record in oldrecorded to include an apostrophe in the subtitle field

iv) ran mythbackend --resched -- the rule no longer matched the oldrecorded entry and set it to rerecord (as expected)

v) edited the showing's program entry to include an apostrophe in the subtitle field

vi) reran mythbackend --resched -- the rule matched the oldrecorded entry and flagged the episode as "Never Record" and thus was not scheduled to record (as expected)

Tested other dupe matching methods, and all worked as expected. Note this tested a previous show flagged as Never Record rather than Previously Recorded.

comment:5 Changed 10 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Tested again by setting the entry in oldrecorded to mimic a previously recorded episode (thanks to sphery in #mythtv-users for the suggestion). Same end result as with previous test - the episode was marked "Duplicate" and was not scheduled to record.

comment:6 Changed 10 years ago by sphery

Resolution: worksforme
Status: infoneeded_newclosed

Issue does not exist on trunk (thanks for testing, Nick), and I cannot reproduce it on 0.21-fixes (using "Merlin" episode "Le Morte D'Arthur" with programid removed to actually perform title+subtitle check).

If the reporter is still seeing this behavior, please ask about it on the mythtv-users list as there's more going on with duplicate matching than may be apparent at first glance.

Note: See TracTickets for help on using tickets.