Opened 12 years ago

Closed 11 years ago

#5382 closed defect (fixed)

Trunk svn 17359 can't insert tables in an empty new database

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Maybe this is known already but here goes.

I just tried latest trunk and removed my 0-21 fixes database to get a clean DB with trunk, but when i run mythtv-setup it won't create any tables except shemalock. So i put my old 021-fixes DB back and run mythtv-setup again and then it upgraded it to the right version.

Clean (empty mythconverg) DB does not work. Upgrade from existing 021-fixes DB is ok.

Change History (2)

comment:1 Changed 12 years ago by sphery <mtdean@…>

Pretty sure this is a duplicate of #5250 and #5267.

The patch in #5314 should "fix" the issue for both trunk and -fixes. The patches in #5286 and #5312 should also be applied to trunk, but are more properly long-term fixes (i.e. they fix the problems, not the symptom, whereas #5314 fixes the symptom so the problem never surfaces).

comment:2 Changed 11 years ago by danielk

Resolution: fixed
Status: newclosed

fixed in trunk, see [17820] and [17637].

Note: See TracTickets for help on using tickets.