Opened 11 years ago

Closed 11 years ago

#5392 closed defect (invalid)

HDHomerun recording corruption

Reported by: DannyCan@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords: playback flicker error stop
Cc: Ticket locked: no

Description

About a month ago or so one of my local digital OTA channels started having video playback issues with mythfrontend. It will have very noticeable jitter about every second and after about 5-10 minutes the playback will just stop until I hit pause/play or exit/reenter.

I am using a HDHomeRun connected to a DB-4 antenna located in my attic and the reception is very good. The channel is KDNL-DT in Saint Louis Missouri.

I have uploaded a sample clip which should show the jitter to filecrunch.com ch30error.ts

I am also attaching the log from the "mythfrontend -v playback > ch30error.txt" command cut to show the time of playback and stop. It starts at the beginning of playback and ends at the stop where it shows repeated "NVP: Waiting for prebuffer" counting up nonstop.

I am running the latest MythTV .21 fixes as of sometime last week.

Attachments (1)

ch30error.txt (21.8 KB) - added by DannyCan@… 11 years ago.
mythfrontend -v playback command output

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by DannyCan@…

Attachment: ch30error.txt added

mythfrontend -v playback command output

comment:1 Changed 11 years ago by DannyCan@…

I believe it is a problem with the ffmpeg codec because I also see jitter in Mplayer, ffplay, and VLC. I have uploaded another sample clip with lots of motion so the jitter is easier to see fastmotion.ts and submitted an ffmpeg ticket so they can try to fix the codec issue462

comment:2 Changed 11 years ago by DannyCan@…

I no longer believe it is a problem with the ffmpeg codec because I am now seeing some new behavior.
When I record on this channel using the HDHomeRun software I get no corruption and it plays fine using direct show codecs, VLC, mplayer, and the MythVideo? Internal player.
But when I record using mythbackend I get nonstop corruption.
I have tried deleting and rescanning for channels with no effect on the corruption.
Is it possible to take a clean recording from the HDHomeRun software and send it through mythbackend as if it were recording it somehow so I can confirm this?

Also, I think the sample video that I provided was recorded with mythbackend.

comment:3 Changed 11 years ago by DannyCan@…

I forgot to mention that I am now using the MythTV .21-fixes weekly build repository provided by Mythbuntu which is currently at version #17490.

mythbackend --version
Please include all output in bug reports.
MythTV Version   : 17416
MythTV Branch    : branches/release-0-21-fixes
Library API      : 0.21.20080304-1
Network Protocol : 40
Options compiled in:
 linux profile using_oss using_alsa using_arts
 using_jack using_backend using_dbox2 using_dvb
 using_firewire using_frontend using_hdhomerun 
using_iptv using_ivtv using_joystick_menu 
using_libfftw3 using_lirc using_opengl_vsync 
using_opengl_video using_v4l using_x11
 using_xrandr using_xv using_xvmc using_xvmcw 
using_xvmc_vld using_glx_proc_addr_arb
 using_bindings_perl using_bindings_python
 using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

comment:4 Changed 11 years ago by stuartm

Summary: Video playback issues on one digital OTA channelHDHomerun recording corruption

comment:5 Changed 11 years ago by DannyCan@…

Hello everyone, I managed to fix this by replacing the NIC on my mythbackend server.
Somehow the old NIC was corrupting the data coming from that channel and nothing else.
You can go ahead and close this ticket.

comment:6 Changed 11 years ago by stuartm

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.