Opened 12 years ago

Closed 11 years ago

#5410 closed defect (fixed)

memory leak in myth-backend on x64 when recording from DVB-C / qam256

Reported by: anonymous Owned by: stuartm
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Bug forwarded from the Mythbuntu bug tracker:


When recording from a "Satelco EasyWatch? DVB-C MK3" DVB-C card I see a memory leak in mythtv-backend. The system seems to allocate about 0.2% of the 4Gb ram installed in the backend every minute until the memory usage rises to about 80% then the system starts swapping and becomes totally unusable. When the recording is finished the memory is not released. The only way to release the memory is to stop/start the mythtv-backend process.

kernel 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux.

My cable provider sends DVB-C in QAM256.

The problem could be related to EIT and the option "Close DVB card when not it use".

mythbackend version: 0.21.20080304-1

I've run the backend under valgrind and have attached the log file.

Valgrind started with the following options:- valgrind --leak-check=full --error-limit=no --show-reachable=yes --log-file=logfile -v -- /usr/bin/mythbackend --daemon --logfile /var/log/mythtv/mythbackend.log --pidfile /var/run/mythtv/mythbackend.pid --noupnp | tee backend.log

Regards Ian Dobson


The OP also suggests:


I've done abit more testing and the leak only happens on some channels. At the moment I can say that the leak happens on channel ProSieben? (Pro7). Note I can watch the programms recorded from ProSieben? without any problems.

After abit of googling I've come across several comments about "encoding fixups for German networks"


Logs attached.

Attachments (2)

mythbackend.txt.gz (11.4 KB) - added by laga+mythtv@… 12 years ago.
valgrind.txt.gz (55.8 KB) - added by laga+mythtv@… 12 years ago.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by laga+mythtv@…

Attachment: mythbackend.txt.gz added

Changed 12 years ago by laga+mythtv@…

Attachment: valgrind.txt.gz added

comment:1 Changed 12 years ago by laga+mythtv@…

Feel free to take a look at the original ticket for uncompressed log files and a memory usage graph: https://bugs.launchpad.net/ubuntu/+source/mythtv/+bug/237137

comment:2 Changed 11 years ago by i.dobson(at)planet-ian.com

Upgraded mythtv-backend to 0.21.0+fixes17453, kernel to 2.6.24-18-generic leak still happening.

comment:3 Changed 11 years ago by anonymous

Upgraded mythtv-backend to 0.21.0+fixes17490, tested with a "KNC One TV-Station " card and still seeing the leak.

comment:4 Changed 11 years ago by laga@…

Ian Dobson claims this issue has been fixed by a recent update to the release-0-21-fixes branch.

comment:5 Changed 11 years ago by stuartm

Owner: changed from Isaac Richards to stuartm
Status: newaccepted

I'll double check the valgrind log first before closing, I'm not sure what backported fixes would fixed this issue.

comment:6 Changed 11 years ago by stuartm

Resolution: fixed
Status: acceptedclosed

I can't see how it was fixed - only two commits were made to mpeg/dvb stream handling in -fixes, one just added FreeSat? EIT support [17502], the other was an EIT character encoding fix [18228].

Closing anyway, please re-open the ticket if the problem is seen again.

Note: See TracTickets for help on using tickets.