Opened 12 years ago

Closed 12 years ago

#5422 closed defect (duplicate)

When ripping a DVD using "Good" or "Perfect" where there is "copy protection", MythDVD does not throw an error.

Reported by: jon@… Owned by: Anduin Withers
Priority: minor Milestone: 0.21.1
Component: mythdvd Version: unknown
Severity: medium Keywords: DVDPerfectThread Copy Protection
Cc: Ticket locked: no

Description

When ripping a DVD with "copy protection" which consists of bad blocks purposely inserted in the image, the "Good" and "Perfect" quality rip fails to work, and jumps to the next transcoding operation or the screen offering to rip a new image.

There is no reason provided as to why the rip failed. This is only identified by reading /var/lib/mythdvd/mtd.txt where the following text is produced:

Error: DVDPerfectThread read failed for X blocks at Y

This defect could be fixed in one of two ways (a short-term and long-term fix?).

1) Either, return an error when performing a DVD rip to show that there was enhanced (heh) copy protection on the DVD, and as such, ripping this DVD should be performed at ISO, or

2) Fix the ripping to try to use something like the script at http://mythtv.org/pipermail/mythtv-users/2007-April/175899.html to "clean" the copied ISO before transcoding it.

Jon

Change History (1)

comment:1 Changed 12 years ago by Anduin Withers

Resolution: duplicate
Status: newclosed

Duplicate of #1140

Note: See TracTickets for help on using tickets.