Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5431 closed defect (invalid)

Jitter/speed pulsing when playing PAL 25Hz/50Hz source on 60Hz display

Reported by: lists@… Owned by: Isaac Richards
Priority: major Milestone: 0.22
Component: mythtv Version: 0.21
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Symptoms as described in this (old) thread:

http://www.mythtv.org/pipermail/mythtv-dev/2004-December/029601.html

Rationale: Most LCD TV's are incapable of anything less than 60Hz modelines over VGA, which is a big problem for UK users since most (all?) TV over here is 25Hz/50Hz PAL.

Are there any framerate up-scaling techniques that can be used to overcome this? I noticed that mplayer does not exhibit the same symptoms.

Change History (3)

comment:1 Changed 11 years ago by anonymous

Just to add, this seems to apply to all MPEG decoders, all video renderers and deinterlacers. Additional, OpenGL Vsync does not improve the situation (in fact on my hardware it's worse).

comment:2 Changed 11 years ago by danielk

Resolution: invalid
Status: newclosed

If you see something different in mplayer than mythtv, there is something wrong with your setup.

comment:3 Changed 11 years ago by mail@…

Reopening – just tested a DVB stream with a horizontal ticker and mplayer does exhibit the same symptoms.

I have reproduced the symptoms on a number of systems and TVs, and the problem is consistent accross all DVB-T Freeview streams on TVs at 60Hz. TVs capable of running at 50Hz (via DVI->HDMI) do not.

Note: See TracTickets for help on using tickets.