Opened 11 years ago

Closed 11 years ago

#5448 closed defect (worksforme)

MythWeb/ofdb.py can't handle apostrophes (')

Reported by: edi@… Owned by: Rob Smith
Priority: trivial Milestone: unknown
Component: mythweb Version: unknown
Severity: medium Keywords: apostrophe ofdb.py mythweb
Cc: Ticket locked: no

Description

If you have an apostrophe in the movie title, like in Is' was Sherif (alternate title: Der wilde wilde Westen, original title Blazing Saddles) wont work, because the name is quoted out in the JavaScript?-Link javascript:imdb_select('1744','15142,Is'-was-Sheriff'). Same with Mike's New Car and Luxo Jr. in 'Surprise' and 'Light & Heavy '. Should maybe escaped out (\') or find another solution.

You can click the link in the list, but nothing will happen.

web_video_imdb_type: ALLOCINETYPE

web_video_imdb_path: /usr/share/mythtv/mythvideo/scripts/ofdb.py -R Switzerland,Germany

Change History (2)

comment:1 Changed 11 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: newaccepted

comment:2 Changed 11 years ago by Rob Smith

Resolution: worksforme
Status: acceptedclosed

I can't reproduce, as we do output the title with addslashes(), which escapes it correctly for me.

Note: See TracTickets for help on using tickets.